It is currently January 26th, 2021, 10:17 pm

Gadgets 5.5.1 - inspired by AddGadgets.com Sidebar Gadgets

A package of skins with a "theme" or by a single author
noteasybeingreen
Posts: 3
Joined: January 7th, 2021, 8:07 pm

Re: Gadgets 5.5.1 - inspired by AddGadgets.com Sidebar Gadgets

Post by noteasybeingreen »

SilverAzide wrote: January 8th, 2021, 12:55 pm Thanks guys, I appreciate the kind words! I'm just glad you are enjoying the Gadgets! :great:
Very much so! Thank you for your hard work. Your passion definitely comes through in your work and forum participation.

Well said by @VL4DST3R above. I'm far from well-off (maybe we'll pay off student loans this decade :confused: ), but long story short...my wife and I are generally frugal people (not cheap! big difference! :D ), so we may allocate more resources towards people/experiences responsible for bringing happiness, laughs and smiles to our lives. Through your rainmeter gadgets and top notch support, you have been one of those people @SilverAzide! Happy to send a dono your way or to your favorite charity, if you prefer.

Either way, thank you for everything. Keep up the good work. Hope this finds you and your family well. Enjoy the rest of your day, have a great weekend and I hope 2021 is as rewarding for you as you deserve.
User avatar
qazserNOS
Posts: 6
Joined: November 21st, 2020, 7:24 pm

Re: Gadgets 5.5.1 - inspired by AddGadgets.com Sidebar Gadgets

Post by qazserNOS »

My computer is on pretty much 24/7. One night the Network Meter Current count changed to negative values.

It looks like this:
https://imgur.com/YzuoK4F

Resetting the count(s) help for a while until it happens again. This has happened a few times now. If I remember correctly, this started after when I changed my motherboard.

Any idea how to fix this?
User avatar
SilverAzide
Rainmeter Sage
Posts: 1100
Joined: March 23rd, 2015, 5:26 pm

Re: Gadgets 5.5.1 - inspired by AddGadgets.com Sidebar Gadgets

Post by SilverAzide »

qazserNOS wrote: January 13th, 2021, 2:39 pm My computer is on pretty much 24/7. One night the Network Meter Current count changed to negative values.

It looks like this:
https://imgur.com/YzuoK4F

Resetting the count(s) help for a while until it happens again. This has happened a few times now. If I remember correctly, this started after when I changed my motherboard.

Any idea how to fix this?
Interesting! This seems like a numeric overflow situation to me. Which skin are you using, the "Network Meter" or "Network Meter Pro"?
Gadgets Wiki GitHub More Gadgets...
User avatar
qazserNOS
Posts: 6
Joined: November 21st, 2020, 7:24 pm

Re: Gadgets 5.5.1 - inspired by AddGadgets.com Sidebar Gadgets

Post by qazserNOS »

SilverAzide wrote: January 13th, 2021, 4:51 pm Interesting! This seems like a numeric overflow situation to me. Which skin are you using, the "Network Meter" or "Network Meter Pro"?
I'm using "Network Meter". I just confirmed it by switching to the Pro variant and back. The Pro variant showed all zeroes for the counts but I didn't even check the config for it. When I switched back the Current count was reset but the Total count resumed. The Gadget version is of course 5.5.1.
User avatar
SilverAzide
Rainmeter Sage
Posts: 1100
Joined: March 23rd, 2015, 5:26 pm

Re: Gadgets 5.5.1 - inspired by AddGadgets.com Sidebar Gadgets

Post by SilverAzide »

qazserNOS wrote: January 13th, 2021, 5:55 pm I'm using "Network Meter". I just confirmed it by switching to the Pro variant and back. The Pro variant showed all zeroes for the counts but I didn't even check the config for it. When I switched back the Current count was reset but the Total count resumed. The Gadget version is of course 5.5.1.
OK, thanks for this info, it will help with debugging. I suspect that what you might be seeing is a numeric overflow error; when certain integer values overflow, the numbers show negative values. This appears to be something in Rainmeter, or perhaps some oddity with your network adapter software. It might not be related to your new motherboard directly, it may be the new network interface on that motherboard.

Here's what you can try. Leave the skin active for a while, or try copying a large amount of data over your network (> 2 or 4 gigs), until it starts showing negative values. Then, open the Rainmeter About screen and on the skin tab select the Network Meter, like this:
screenshot.jpg
Check the measures in the red boxes; you will see your negative values here. Screenshot this (showing all the NetIn and NetOut measures, including the ones not in the boxes), and post it here.
You do not have the required permissions to view the files attached to this post.
Gadgets Wiki GitHub More Gadgets...
User avatar
qazserNOS
Posts: 6
Joined: November 21st, 2020, 7:24 pm

Re: Gadgets 5.5.1 - inspired by AddGadgets.com Sidebar Gadgets

Post by qazserNOS »

SilverAzide wrote: January 13th, 2021, 7:40 pm OK, thanks for this info, it will help with debugging. I suspect that what you might be seeing is a numeric overflow error; when certain integer values overflow, the numbers show negative values. This appears to be something in Rainmeter, or perhaps some oddity with your network adapter software. It might not be related to your new motherboard directly, it may be the new network interface on that motherboard.

Here's what you can try. Leave the skin active for a while, or try copying a large amount of data over your network (> 2 or 4 gigs), until it starts showing negative values. Then, open the Rainmeter About screen and on the skin tab select the Network Meter, like this:

screenshot.jpg

Check the measures in the red boxes; you will see your negative values here. Screenshot this (showing all the NetIn and NetOut measures, including the ones not in the boxes), and post it here.
Thanks for the help. I'll get back to you when the negative values present themselves again. It might take a while, a couple of weeks maybe. I already downloaded over 12GB and uploaded over 5GB according to the Current count.

Before this issue I almost never reset the Current count and had it show values in the terabytes, matching the Total value.
User avatar
SilverAzide
Rainmeter Sage
Posts: 1100
Joined: March 23rd, 2015, 5:26 pm

Re: Gadgets 5.5.1 - inspired by AddGadgets.com Sidebar Gadgets

Post by SilverAzide »

qazserNOS wrote: January 13th, 2021, 10:56 pm Thanks for the help. I'll get back to you when the negative values present themselves again. It might take a while, a couple of weeks maybe. I already downloaded over 12GB and uploaded over 5GB according to the Current count.

Before this issue I almost never reset the Current count and had it show values in the terabytes, matching the Total value.
The numbers should not overflow until you are in the exabyte range, so unless you are running a Google or Amazon server farm, you should never see that in your lifetime.... ;-) Just please don't reset the numbers once you see negative values so we can trace down where they are coming from. It would also help that once you see the negative numbers, in addition to the screenshot, post the contents of your Rainmeter.stats file.
This file is C:\Users\<username>\AppData\Roaming\Rainmeter\Rainmeter.stats.
Gadgets Wiki GitHub More Gadgets...
Vespers
Posts: 1
Joined: April 3rd, 2020, 4:35 pm

Re: Gadgets 5.5.1 - inspired by AddGadgets.com Sidebar Gadgets

Post by Vespers »

I just got say OMG! I love Gadgets!
Image
Takes a little bit of time understanding... I've been trying to understand the setting, trying to find the correct location to turn off 'chime on the hour' annoying thing. the mute wasn't working. Spent hours scouring thru old posts and TG for that wiki write up!
Thank you SilverAzide!!!!! Superb Job! :thumbup:
User avatar
VL4DST3R
Posts: 32
Joined: November 17th, 2018, 12:20 am
Location: Romania

Re: Gadgets 5.5.1 - inspired by AddGadgets.com Sidebar Gadgets

Post by VL4DST3R »

Hey, just a quick question, is there a way to adjust the fan speed bar/graph scale? For example my CPU fan tops at 1500rpm max, but that's about ~35% of the entire scale, and I'd like it to represent 100% instead.
Last edited by VL4DST3R on January 14th, 2021, 2:01 pm, edited 1 time in total.
User avatar
SilverAzide
Rainmeter Sage
Posts: 1100
Joined: March 23rd, 2015, 5:26 pm

Re: Gadgets 5.5.1 - inspired by AddGadgets.com Sidebar Gadgets

Post by SilverAzide »

Vespers wrote: January 14th, 2021, 4:48 am I just got say OMG! I love Gadgets!
Takes a little bit of time understanding... I've been trying to understand the setting, trying to find the correct location to turn off 'chime on the hour' annoying thing. the mute wasn't working. Spent hours scouring thru old posts and TG for that wiki write up!

Thank you SilverAzide!!!!! Superb Job! :thumbup:
You are welcome! Glad you are enjoying the Gadgets! :welcome:
Gadgets Wiki GitHub More Gadgets...