It is currently October 22nd, 2021, 10:06 pm

Gadgets 7.1.1 - inspired by AddGadgets.com Sidebar Gadgets

A package of skins with a "theme" or by a single author
User avatar
SilverAzide
Rainmeter Sage
Posts: 1616
Joined: March 23rd, 2015, 5:26 pm

Re: Gadgets 5.5.1 - inspired by AddGadgets.com Sidebar Gadgets

Post by SilverAzide »

Arbitria wrote: November 26th, 2020, 10:06 am Rainmeter Forum, hello!

AddGadgets.com gadgets are an ever-pleasing breeze of important little details right in the face of the computer age.
They have more fans than you can count.

@SilverAzide, there is a problem on Virustotal, some antiviruses identify gadgets as malware:

Gadgest 5.5.1
https://www.virustotal.com/gui/file/4a49f7b7ad822cf82340bdf08b69451c23f08074641349437f425ed9053ab39e/detection
Top Process 5.2.0
https://www.virustotal.com/gui/file/6b4fcc203f96bc3ec553ce3327aa17c99b61d121d4c951730ccb5574391ad122/detection

Thoughts ?!
Hello! Glad you like the Gadgets! These are false positives. These Gadgets contain a common utility executable, RainRGB (the color picker tool), that sometimes gets incorrectly flagged. I think it is because it was written in a programming language that script-kiddies like to use to create malware. It is safe to use (it was written by one of the Rainmeter devs for the community to use), but you can delete it if you want. You'll just need to select colors some other way and enter the RGB values yourself. I may replace this utility with one created with Rainmeter at some point.
Gadgets Wiki GitHub More Gadgets...
User avatar
balala
Rainmeter Sage
Posts: 13340
Joined: October 11th, 2010, 6:27 pm
Location: Gheorgheni, Romania

Re: Gadgets 5.5.1 - inspired by AddGadgets.com Sidebar Gadgets

Post by balala »

SilverAzide wrote: November 26th, 2020, 4:04 pm These are false positives. These Gadgets contain a common utility executable, RainRGB (the color picker tool), that sometimes gets incorrectly flagged.
Same way the NirCmd is also detected by VirusTotal as being infected, even if it is not.
b1tbull
Posts: 2
Joined: December 7th, 2020, 1:16 pm

Re: Gadgets 5.5.1 - inspired by AddGadgets.com Sidebar Gadgets

Post by b1tbull »

Greetings,

Last week addgadgets and windows sidebar broke down for reason unknown. Two system restores did not fix the issue. For more than a decade my second screen was filled with a dozen system monitoring gadgets.
So what a relief that you developed and made available an almost perfect clone of my favorite addgadgets.
Thanks a million and keep up the good work. :bow:

Francis
Zejott
Posts: 4
Joined: December 7th, 2020, 4:12 pm

All CPU Meter CPU Fan Speed not working

Post by Zejott »

The "All CPU Meter" Skin found in SilverAzide's "Gadgets" Suite v5.1.1 (https://forum.rainmeter.net/viewtopic.php?t=20699) isn't showing CPU fan speed. I'm using HWiNFO64 to read the sensors. I followed the given instructions (https://github.com/SilverAzide/Gadgets/wiki/HOW-TO-Configure-the-All-CPU-Meter-to-show-fan-usage#how-to-configure-the-all-cpu-meter-to-show-fan-usage) and edited the HWiNFO settings according to my sensor IDs, which can be seen in the screenshots below. All the other sensor readings are shown correctly, except the CPU fan speed.
sensors.JPG
sensor ID of mainboard CPU FAN sensor
settings.JPG
settings i put in the HWiNFO settings file

Does anynone have an idea how to fix this?
You do not have the required permissions to view the files attached to this post.
User avatar
SilverAzide
Rainmeter Sage
Posts: 1616
Joined: March 23rd, 2015, 5:26 pm

Re: Gadgets 5.5.1 - inspired by AddGadgets.com Sidebar Gadgets

Post by SilverAzide »

b1tbull wrote: December 7th, 2020, 1:26 pm Greetings,

Last week addgadgets and windows sidebar broke down for reason unknown. Two system restores did not fix the issue. For more than a decade my second screen was filled with a dozen system monitoring gadgets.
So what a relief that you developed and made available an almost perfect clone of my favorite addgadgets.
Thanks a million and keep up the good work. :bow:

Francis
Thanks, glad you like the Gadgets! You get kudos for being able to keep the old ones alive for so long. They stopped working for me about 5 years ago, which is why I built these. If you want more, check out my GitHub site. There are a TON more on dudebaker's site, Gadgets Additions. He's got all the stock market gadgets replicated, plus a bunch more.
Gadgets Wiki GitHub More Gadgets...
User avatar
SilverAzide
Rainmeter Sage
Posts: 1616
Joined: March 23rd, 2015, 5:26 pm

Re: All CPU Meter CPU Fan Speed not working

Post by SilverAzide »

Zejott wrote: December 7th, 2020, 4:37 pm The "All CPU Meter" Skin found in SilverAzide's "Gadgets" Suite v5.1.1 (https://forum.rainmeter.net/viewtopic.php?t=20699) isn't showing CPU fan speed. I'm using HWiNFO64 to read the sensors. I followed the given instructions (https://github.com/SilverAzide/Gadgets/wiki/HOW-TO-Configure-the-All-CPU-Meter-to-show-fan-usage#how-to-configure-the-all-cpu-meter-to-show-fan-usage) and edited the HWiNFO settings according to my sensor IDs, which can be seen in the screenshots below. All the other sensor readings are shown correctly, except the CPU fan speed.

Does anynone have an idea how to fix this?
Hello,
It looks like you have configured HWiNFO correctly. (Thanks for the screenshot!) One thing I have to ask (sorry, I know this might be obvious), but did you check BOTH the "Show Core Temps" and "Show Fan Usage" options in the Settings?
Screenshot 2020-12-07 120857.png
You do not have the required permissions to view the files attached to this post.
Gadgets Wiki GitHub More Gadgets...
Zejott
Posts: 4
Joined: December 7th, 2020, 4:12 pm

Re: Gadgets 5.5.1 - inspired by AddGadgets.com Sidebar Gadgets

Post by Zejott »

SilverAzide wrote: December 7th, 2020, 5:11 pm
Hello,
It looks like you have configured HWiNFO correctly. (Thanks for the screenshot!) One thing I have to ask (sorry, I know this might be obvious), but did you check BOTH the "Show Core Temps" and "Show Fan Usage" options in the Settings?
Screenshot 2020-12-07 120857.png
Hi,
yes, both the "show core temps" and "show fan usage" options are ticked.
User avatar
SilverAzide
Rainmeter Sage
Posts: 1616
Joined: March 23rd, 2015, 5:26 pm

Re: Gadgets 5.5.1 - inspired by AddGadgets.com Sidebar Gadgets

Post by SilverAzide »

Zejott wrote: December 7th, 2020, 5:36 pm Hi,
yes, both the "show core temps" and "show fan usage" options are ticked.
OK, great... Do you see any errors in the Rainmeter Log on the About screen? You should see a notice like "HWiNFO detected", but nothing else. I should also ask, is there any chance you are running CoreTemp or SpeedFan in addition to HWiNFO? If you are running either of these, they take precedence over HWiNFO. The log will tell you which is in use.

Another thing to check is the Skins tab on the About screen. Select the All CPU Meter skin and scroll down until you see the 5 fan measures shown here:
Screenshot 2020-12-07 125520.png
The green highlighted measure and the one below it are for SpeedFan, and they should be grayed out (disabled). The last three items should be enabled, and should be showing non-zero values if your fan is spinning. The yellow highlighted line is your fan speed.
You do not have the required permissions to view the files attached to this post.
Gadgets Wiki GitHub More Gadgets...
Zejott
Posts: 4
Joined: December 7th, 2020, 4:12 pm

Re: Gadgets 5.5.1 - inspired by AddGadgets.com Sidebar Gadgets

Post by Zejott »

SilverAzide wrote: December 7th, 2020, 5:46 pm OK, great... Do you see any errors in the Rainmeter Log on the About screen? You should see a notice like "HWiNFO detected", but nothing else. I should also ask, is there any chance you are running CoreTemp or SpeedFan in addition to HWiNFO? If you are running either of these, they take precedence over HWiNFO. The log will tell you which is in use.

Another thing to check is the Skins tab on the About screen. Select the All CPU Meter skin and scroll down until you see the 5 fan measures shown here:
Screenshot 2020-12-07 125520.png
The green highlighted measure and the one below it are for SpeedFan, and they should be grayed out (disabled). The last three items should be enabled, and should be showing non-zero values if your fan is spinning. The yellow highlighted line is your fan speed.
CoreTemp was indeed running simultaneously to HWiNFO, but even after fully deinstalling CoreTemp and rebooting it still wouldn't work, so I checked the log. It shows one warning saying Rainmeter couldn't detect HWiNFO, but half a second later it does so I guess thats allright.
log.png
In the Skins tab however, not only the SpeedFan measures but all of them, including the HWiNFO ones, are grayed out.
Screenshot 2020-12-07 213207.png
You do not have the required permissions to view the files attached to this post.
Zejott
Posts: 4
Joined: December 7th, 2020, 4:12 pm

Re: Gadgets 5.5.1 - inspired by AddGadgets.com Sidebar Gadgets

Post by Zejott »

Zejott wrote: December 7th, 2020, 8:43 pm CoreTemp was indeed running simultaneously to HWiNFO, but even after fully deinstalling CoreTemp and rebooting it still wouldn't work, so I checked the log. It shows one warning saying Rainmeter couldn't detect HWiNFO, but half a second later it does so I guess thats allright.

log.png

In the Skins tab however, not only the SpeedFan measures but all of them, including the HWiNFO ones, are grayed out.

Screenshot 2020-12-07 213207.png
So I just noticed that the CPU temperature readings are gone aswell since deactivating CoreTemp. I guess that's what the Warning message in the Log was referring to.

Checking the sensor IDs for the CPU temperatures in the HWiNFO settings file I noticed the IDs were incorrect. So the skin was basically getting the temperature readings from CoreTemp the whole time. After correcting the CPU Temperature sensor IDs not only the temperature was showing correctly but also the fan speed indicator started working without any further changes - job done!

Thanks for the help!