It is currently May 20th, 2022, 10:29 am

Turn Off Text Shadow?

General topics related to Rainmeter.
mattie3317
Posts: 9
Joined: December 4th, 2010, 6:23 am

Turn Off Text Shadow?

Post by mattie3317 »

I just discovered Rainmeter today and am loving it. :D I want to use the Gnometer theme and have a white bar with black font (similar to a mac) but when I do so black text shadow becomes obvious and distorts the font. I'm wondering if there is any way to turn the shadow off completely. Thanks :welcome:
You do not have the required permissions to view the files attached to this post.
poiru
Developer
Posts: 2872
Joined: April 17th, 2009, 12:18 pm

Re: Turn Off Text Shadow?

Post by poiru »

mattie3317 wrote:I just discovered Rainmeter today and am loving it. :D I want to use the Gnometer theme and have a white bar with black font (similar to a mac) but when I do so black text shadow becomes obvious and distorts the font. I'm wondering if there is any way to turn the shadow off completely. Thanks :welcome:
I might add an option to disable this in Gnometer 1.3.0.3, but for now, open Gnometer\SETTINGS\StyleXX.inc (where XX is the style you're currently using) and change all instances of StringEffect=SHADOW to StringEffect=NONE.
mattie3317
Posts: 9
Joined: December 4th, 2010, 6:23 am

Re: Turn Off Text Shadow?

Post by mattie3317 »

poiru wrote: I might add an option to disable this in Gnometer 1.3.0.3, but for now, open Gnometer\SETTINGS\StyleXX.inc (where XX is the style you're currently using) and change all instances of StringEffect=SHADOW to StringEffect=NONE.
I just tried this (I had to save to my documents and then copy it into the folder to work around an access denied message) but the text still has shadow. I've refreshed the skin and even restarted my computer. I just applied the modification to the other skins thinking I am somehow using a different one, but no luck.
User avatar
Kaelri
Developer
Posts: 1721
Joined: July 25th, 2009, 4:47 am

Re: Turn Off Text Shadow?

Post by Kaelri »

mattie3317 wrote:I just tried this (I had to save to my documents and then copy it into the folder to work around an access denied message) but the text still has shadow. I've refreshed the skin and even restarted my computer. I just applied the modification to the other skins thinking I am somehow using a different one, but no luck.
Did you change your Rainmeter Skins folder? I ask because you mentioned copying the files out of My Documents, but your default skins folder should be in My Documents(\Rainmeter\Skins), and not in e.g. C:\Program Files\Rainmeter.
mattie3317
Posts: 9
Joined: December 4th, 2010, 6:23 am

Re: Turn Off Text Shadow?

Post by mattie3317 »

Kaelri wrote: Did you change your Rainmeter Skins folder? I ask because you mentioned copying the files out of My Documents, but your default skins folder should be in My Documents(\Rainmeter\Skins), and not in e.g. C:\Program Files\Rainmeter.
Oh I was changing it in C:\Program Files\Rainmeter. My bad. Thanks for the help though, it looks a lot cleaner now :D