It is currently February 23rd, 2024, 4:58 am

Does the plugin 'FileView' have a bug?

Report bugs with the Rainmeter application and suggest features.
User avatar
DanielPodo
Posts: 77
Joined: March 30th, 2016, 1:50 pm

Does the plugin 'FileView' have a bug?

Post by DanielPodo »

Upon updating one of my skins, when I was checking the main config file which loads all the images used by the skin, I noticed something strange.

I wanted to add a few more icons to the theme and update the mentioned skin, so for every type of skin (OS, RAM, CPU etc) I should see 6 icons in total. This is when I realised that some of the icons weren't loading.

Here's what I discovered. If you implement the following code...everything works. Count is set to 7, and the indexing starts from 2.

Code: Select all

[BinPath]
Measure=Plugin
Plugin=FileView
Path=#ResourcesPath#\Bin
Count=7

[BinChild1]
Measure=Plugin
Plugin=FileView
Path=[BinPath]
Type=FileName
Index=2

[BinChild2]
Measure=Plugin
Plugin=FileView
Path=[BinPath]
Type=FileName
Index=3

[BinChild3]
Measure=Plugin
Plugin=FileView
Path=[BinPath]
Type=FileName
Index=4

[BinChild4]
Measure=Plugin
Plugin=FileView
Path=[BinPath]
Type=FileName
Index=5

[BinChild5]
Measure=Plugin
Plugin=FileView
Path=[BinPath]
Type=FileName
Index=6

[BinChild6]
Measure=Plugin
Plugin=FileView
Path=[BinPath]
Type=FileName
Index=7
But if you implement this code...one icon goes missing. Note that the only difference is that Count is set to 6, and the indexing starts from 1.

What is going on? Surely with 6 files in the folder, starting from index 1 going to 6, all 6 files should be visible? The info on the FileView plugin doesn't mention anything about having to start from 2 onwards, yet this is the only way I can get the entire skin to work...

Code: Select all

[BinPath]
Measure=Plugin
Plugin=FileView
Path=#ResourcesPath#\Bin
Count=6

[BinChild1]
Measure=Plugin
Plugin=FileView
Path=[BinPath]
Type=FileName
Index=1

[BinChild2]
Measure=Plugin
Plugin=FileView
Path=[BinPath]
Type=FileName
Index=2

[BinChild3]
Measure=Plugin
Plugin=FileView
Path=[BinPath]
Type=FileName
Index=3

[BinChild4]
Measure=Plugin
Plugin=FileView
Path=[BinPath]
Type=FileName
Index=4

[BinChild5]
Measure=Plugin
Plugin=FileView
Path=[BinPath]
Type=FileName
Index=5

[BinChild6]
Measure=Plugin
Plugin=FileView
Path=[BinPath]
Type=FileName
Index=6
User avatar
Yincognito
Rainmeter Sage
Posts: 6781
Joined: February 27th, 2015, 2:38 pm
Location: Terra Yincognita

Re: Does the plugin 'FileView' have a bug?

Post by Yincognito »

DanielPodo wrote: January 30th, 2024, 7:25 pmBut if you implement this code...one icon goes missing. Note that the only difference is that Count is set to 6, and the indexing starts from 1.

What is going on? Surely with 6 files in the folder, starting from index 1 going to 6, all 6 files should be visible? The info on the FileView plugin doesn't mention anything about having to start from 2 onwards, yet this is the only way I can get the entire skin to work...
I suspect this isn't a bug. You might want to check the ShowDotDot option of a FileView parent measure, because I think your "missing icon" is precisely the .. parent folder (which is why you might think something is missing there).
Profiles: Rainmeter ProfileDeviantArt ProfileSuites: MYiniMeterSkins: Earth
User avatar
DanielPodo
Posts: 77
Joined: March 30th, 2016, 1:50 pm

Re: Does the plugin 'FileView' have a bug?

Post by DanielPodo »

Yincognito wrote: January 30th, 2024, 11:48 pm I suspect this isn't a bug. You might want to check the ShowDotDot option of a FileView parent measure, because I think your "missing icon" is precisely the .. parent folder (which is why you might think something is missing there).
You're absolute right, that did the trick. That's easy to miss, I think it should be clarified at the top that this can influence the number of items indexed.