It is currently January 22nd, 2022, 6:02 am

Rainmeter 4.5.6 breaks on Windows Server

Get help with installing and using Rainmeter.
mnaim
Posts: 4
Joined: March 18th, 2016, 8:59 am

Rainmeter 4.5.6 breaks on Windows Server

Post by mnaim »

After update to 4.5.6 it cannot start on any of Windows Server.
Started digging why.

After reading dependencies, it was obvious, that new change introduced dependency on wlanapi.dll, which is not installed on Windows Server versions (in attached picture).

Rainmeter 4.5.6 has in change log this:
WiFiStatus: WiFiStatus was converted from a plugin to a measure.

Solution is to change that to dynamical loading instead of static linking.

Thanks
You do not have the required permissions to view the files attached to this post.
Last edited by mnaim on December 11th, 2021, 11:31 am, edited 1 time in total.
User avatar
SilverAzide
Rainmeter Sage
Posts: 1739
Joined: March 23rd, 2015, 5:26 pm

Re: Rainmeter 4.5.6 breaks on Windows Server

Post by SilverAzide »

mnaim wrote: December 9th, 2021, 10:53 am After update to 4.5.6 it cannot start on any of Windows Server.
Started digging why.

After reading dependencies, it was obvious, that new change introduced dependency on wlanapi.dll, which is not installed on Windows Server versions (in attached picture).

Rainmeter 4.5.6 has in change log this:
WiFiStatus: WiFiStatus was converted from a plugin to a measure.

Solution is to change that to dynamical loading instead of static linking.

Thanks
Your other option is on your server, run the Server Manager, navigate to the "Select Features" tab, and enable the "Wireless LAN Service" (you may need to reboot after installing). This is not enabled by default on servers.
Gadgets Wiki GitHub More Gadgets...
User avatar
jsmorley
Developer
Posts: 22450
Joined: April 19th, 2009, 11:02 pm
Location: Fort Hunt, Virginia, USA

Re: Rainmeter 4.5.6 breaks on Windows Server

Post by jsmorley »

This should be corrected in the just-released version 4.5.7 r3581.
User avatar
Brian
Developer
Posts: 2329
Joined: November 24th, 2011, 1:42 am
Location: Utah

Re: Rainmeter 4.5.6 breaks on Windows Server

Post by Brian »

Please note, this should delay loading of the wlanapi.dll library similar to how Rainmeter loaded it in versions prior to 4.5.6.

What this means is that Rainmeter will not crash when loading, however, it may crash if loading a skin that uses the WifiStatus measure. Obviously this will probably only affect Windows Server versions without wlanapi.dll currently loaded.

-Brian
mnaim
Posts: 4
Joined: March 18th, 2016, 8:59 am

Re: Rainmeter 4.5.6 breaks on Windows Server

Post by mnaim »

SilverAzide wrote: December 9th, 2021, 6:03 pm Your other option is on your server, run the Server Manager, navigate to the "Select Features" tab, and enable the "Wireless LAN Service" (you may need to reboot after installing). This is not enabled by default on servers.
I know, or I can copy dll to Rainmeter folder, but in terms of security I don't want to install and run services on server that are not necessary.
mnaim
Posts: 4
Joined: March 18th, 2016, 8:59 am

Re: Rainmeter 4.5.6 breaks on Windows Server

Post by mnaim »

Brian wrote: December 9th, 2021, 9:01 pm Please note, this should delay loading of the wlanapi.dll library similar to how Rainmeter loaded it in versions prior to 4.5.6.

What this means is that Rainmeter will not crash when loading, however, it may crash if loading a skin that uses the WifiStatus measure. Obviously this will probably only affect Windows Server versions without wlanapi.dll currently loaded.

-Brian
Perfect. 4.5.7 solved problem. Now running again without any issue. Thanks!
User avatar
Jeff
Posts: 245
Joined: September 3rd, 2018, 11:18 am

Re: Rainmeter 4.5.6 breaks on Windows Server

Post by Jeff »

Could this be solved by going to Server Manager > top right Manage thingy > Add Roles and Features then select Features on the left side and then just check "Wireless LAN Service" and install?
NismoZ
Posts: 24
Joined: May 1st, 2020, 3:04 pm

Re: Rainmeter 4.5.6 breaks on Windows Server

Post by NismoZ »

4.5.7 did not fix it for me with Server 2016.

Installing the feature Wireless LAN Service fixed it, but we would rather not install services that are not needed.

Here are some errors from the logs.


Faulting application name: Rainmeter.exe, version: 4.5.7.3581, time stamp: 0x61b2632f
Faulting module name: KERNELBASE.dll, version: 10.0.14393.4770, time stamp: 0x6180883c
Exception code: 0xc06d007e
Fault offset: 0x0000000000034f38
Faulting process id: 0x1c84
Faulting application start time: 0x01d7f1be6e089015
Faulting application path: C:\Program Files\Rainmeter\Rainmeter.exe
Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
Report Id: 06cd614f-d116-4cc6-8718-b687ab18c833
Faulting package full name:


Application: Rainmeter.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: exception code c06d007e, exception address 00007FFA7AEE4F38
Stack:


The Open Procedure for service "WmiApRpl" in DLL "C:\WINDOWS\system32\wbem\wmiaprpl.dll" failed. Performance data for this service will not be available. The first four bytes (DWORD) of the Data section contains the error code.

Unable to open the Server service performance object. The first four bytes (DWORD) of the Data section contains the status code.

The Open Procedure for service ".NETFramework" in DLL "C:\WINDOWS\system32\mscoree.dll" failed. Performance data for this service will not be available. The first four bytes (DWORD) of the Data section contains the error code.

The Open Procedure for service "CcmFramework" in DLL "FrameworkPerf.dll" failed. Performance data for this service will not be available. The first four bytes (DWORD) of the Data section contains the error code.

The Open Procedure for service "BITS" in DLL "C:\Windows\System32\bitsperf.dll" failed. Performance data for this service will not be available. The first four bytes (DWORD) of the Data section contains the error code.
User avatar
CyberTheWorm
Posts: 815
Joined: August 22nd, 2016, 11:32 pm
Location: Surrey, B.C., Canada

Re: Rainmeter 4.5.6 breaks on Windows Server

Post by CyberTheWorm »

This might be a stupid suggestion but had you tried a portable version of rainmeter?
The only source of knowledge is experience. Albert Einstein
Deviant Art Page
User avatar
Brian
Developer
Posts: 2329
Joined: November 24th, 2011, 1:42 am
Location: Utah

Re: Rainmeter 4.5.6 breaks on Windows Server

Post by Brian »

NismoZ wrote: December 15th, 2021, 2:26 pm Installing the feature Wireless LAN Service fixed it, but we would rather not install services that are not needed.
Are you using skins that use the WifiStatus measure? The wlanapi.dll should only load if you are using a skin that uses WifiStatus.

NismoZ wrote: December 15th, 2021, 2:26 pm Here are some errors from the logs.
These errors don't seem related to the wlanapi.dll issue (or at least they don't seem to be referencing wlanapi.dll). They look more like a .NET or perfmon issue.

Have you tried running sfc /scannow ?

-Brian