It is currently June 18th, 2024, 10:58 pm

foreign languages not displaying

Get help with creating, editing & fixing problems with skins
pei
Posts: 7
Joined: April 6th, 2010, 1:23 am

foreign languages not displaying

Post by pei »

I have a custom skin called Black Rock Shooter. I have song from winamps displaying on it, however I noticed that when I play songs that has foreign characters in it (e.g. Japanese, Korean, Chinese) it shows "?????"

I've confirmed that this is only for winamps.
Image
on the left is the same song being played in winamps, while on the right it's itunes.

I've tried using the default Enigma winamp skin, the same thing happened.

I've searched around and found that there was a thread about this, or related atleast.
http://rainmeter.net/forum/viewtopic.php?f=5&t=2022&p=14678&hilit=unicode#p14678

I'm running windows 7 64-bit, rainmeter latest (not beta)

here's the link to the skin I'm talking about.
http://kazasou.wordpress.com/2010/01/19/desktop-goodies-black-rock-shooter-rainmeter/

here's the code

Code: Select all

; Black Rock Shooter Rainmeter
; Author - Kaza-SOU (kazasou.wordpress.com)
; Email  - kaza_sou_luv45@yahoo.com

[Variables]
WinampFolder=c:\progra~1\winamp\

[MeasureWinamp]
Measure=Plugin
Plugin=Plugins\WindowMessagePlugin.dll
WindowClass=Winamp v1.x
Substitute="[Paused]":""," - Winamp":"","[Stopped]":""

[MeasureWinampFull]
Measure=Plugin
Plugin=Plugins\WindowMessagePlugin.dll
WindowClass=Winamp v1.x
WindowMessage=1024 1 105

[MeasureWinampCurr]
Measure=Plugin
Plugin=Plugins\WindowMessagePlugin.dll
WindowClass=Winamp v1.x
WindowMessage=1024 0 105

[MeasureWinampDuration]
Measure=Calc
Formula=MeasureWinampCurr/(MeasureWinampFull*1000+1)

[MeasureWinampCountM]
Measure=Calc
Formula=((MeasureWinampCurr/1000)-29.5)/60
Substitute="-":""

[MeasureWinampCountS]
Measure=Calc
Formula=((MeasureWinampCurr/1000)%60)/10
Substitute="-":"",".":"","60":"00"

[Chara]
Meter=IMAGE
X=25
Y=0
ImageName=blackRock.png

[WaCounterM]
Meter=STRING
MeasureName=MeasureWinampCountM
X=405
Y=51
FontFace=Impact
FontColor=255,255,255,255
FontSize=15
StringAlign=RIGHT
StringStyle=Normal
AntiAlias=1
Postfix=":"
Angle=-0.39

[WaCounterS]
Meter=STRING
MeasureName=MeasureWinampCountS
X=-5r
Y=2r
FontFace=Impact
FontColor=255,255,255,255
FontSize=15
StringAlign=Left
StringStyle=Normal
AntiAlias=1
NumOfDecimals=1
Angle=-0.39

[MeterWATitle]
Meter=STRING
MeasureName=MeasureWinamp
X=420
Y=35
H=15
W=310
FontColor=255,255,255,255
StringStyle=Normal
FontSize=8
StringAlign=RIGHT
FontFace=Impact
AntiAlias=1
ClipString=1
Angle=-0.41

[MeasureDate]
Measure=Time
Format=%#d

[MeasureMonth]
Measure=Time
Format=%b

[MeasureYear]
Measure=Time
Format=%Y

[MeterDate]
Meter=STRING
MeasureName=MeasureDate
X=-27r
Y=16r
FontColor=255,255,255,255
StringStyle=Normal
FontSize=35
StringAlign=RIGHT
FontFace=Impact
AntiAlias=1
Angle=-0.37

[MeterMonth]
Meter=STRING
MeasureName=MeasureMonth
X=-45r
Y=30r
FontColor=255,255,255,255
StringStyle=Normal
FontSize=15
StringAlign=RIGHT
FontFace=Impact
AntiAlias=1
Angle=-0.41

[MeterYear]
Meter=STRING
MeasureName=MeasureYear
X=43r
Y=-3r
FontColor=255,255,255,255
StringStyle=Normal
FontSize=15
StringAlign=LEFT
FontFace=Impact
AntiAlias=1
Angle=-0.39

[MeasureHour]
Measure=Time
Format=%#H

[MeasureTime]
Measure=Time
Format=:%M:%S

[MeterHour]
Meter=STRING
MeasureName=MeasureHour
X=-27r
Y=16r
FontColor=255,255,255,255
StringStyle=Normal
FontSize=35
StringAlign=RIGHT
FontFace=Impact
AntiAlias=1
Angle=-0.37

[MeterTime]
Meter=STRING
MeasureName=MeasureTime
X=-2r
Y=21r
FontColor=255,255,255,255
StringStyle=Normal
FontSize=15
StringAlign=LEFT
FontFace=Impact
AntiAlias=1
Angle=-0.39

[MeasureNetIn]
Measure=NetIn

[MeasureNetOut]
Measure=NetOut

[MeterNetIn]
Meter=STRING
MeasureName=MeasureNetIn
X=145
Y=30
FontColor=255,255,255,255
StringStyle=Normal
FontSize=8
StringAlign=right
FontFace=Impact
AntiAlias=1
AutoScale=0
Scale=1000.00
Prefix="IN: "
PostFix=" k"
NumOfDecimals=1
Angle=-0.47

[MeterNetOut]
Meter=STRING
MeasureName=MeasureNetOut
X=5r
Y=11r
FontColor=255,255,255,255
StringStyle=Normal
FontSize=8
StringAlign=right
FontFace=Impact
AntiAlias=1
AutoScale=0
Scale=1000.00
Prefix="Out: "
PostFix=" k"
NumOfDecimals=1
Angle=-0.47

[MeasureUsedMem]
Measure=PhysicalMemory

[MeasureUsedSwap]
Measure=SwapMemory

[MeterUsedMem]
MeasureName=MeasureUsedMem
Meter=STRING
X=93
Y=234
Percentual=1
FontColor=255,255,255,255
FontSize=7
Align=left
FontFace=Impact
StringStyle=Normal
Prefix="RAM:  "
Postfix="%"
AntiAlias=1
AutoScale=1
Angle=0.70

[MeterUsedSwap]
MeasureName=MeasureUsedSwap
Meter=STRING
X=-8r
Y=8r
Percentual=1
FontColor=255,255,255,255
FontSize=7
Align=left
FontFace=Impact
StringStyle=Normal
Prefix="SWP: "
Postfix="%"
AntiAlias=1
AutoScale=1
Angle=0.70

[MeasureCPU]
Measure=CPU

[MeterCPU%]
Meter=STRING
MeasureName=MeasureCPU
X=175
Y=33
FontColor=255,255,255,255
FontSize=8
Align=left
FontFace=Impact
StringStyle=Normal
AntiAlias=1
AutoScale=1
Angle=0.10
Prefix="CPU: "
Postfix=" %"
User avatar
kenz0
Developer
Posts: 263
Joined: July 31st, 2009, 2:23 pm
Location: Tokyo, JPN

Re: foreign languages not displaying

Post by kenz0 »

Local character issue is really troubling.

Anyway, I think that the cause of this problem is the character code of the ID3 tag.
Usually, the default of the ID3 tag of iTunes is UTF-8. In contrast, Winamp is ISO-8859-1. But recent winamp is supporting UTF-8.
iTunes Plugin is designed on the assumption of UTF-8, but WindowMessage Plugin (i.e. winamp) cannot recognize UTF-8. So in Winamp, the music with the tag of UTF-8 is not correctly displayed except the ASCII character.

To handle a foreign character, it cannot but depend on Unicode. But since it cannot be used, there is no solution.
.
Image
User avatar
jsmorley
Developer
Posts: 22640
Joined: April 19th, 2009, 11:02 pm
Location: Fort Hunt, Virginia, USA

Re: foreign languages not displaying

Post by jsmorley »

I agree that this is a problem kenz0. I have weighed in against "translating" Rainmeter in another thread, but the issue of correctly displaying the user's local character set is a different issue and we need to look for an overall solution.
User avatar
~Faradey~
Posts: 366
Joined: November 12th, 2009, 4:47 pm
Location: Ukraine

Re: foreign languages not displaying

Post by ~Faradey~ »

pei
I have selfmade Winamp skin and config almost like yours but I have no problems.
Maybe you should update your WinAmp. I have 5.57 ver.
pic
Image
and
Image
pei
Posts: 7
Joined: April 6th, 2010, 1:23 am

Re: foreign languages not displaying

Post by pei »

Thanks for the replies guys. I'll update my winamps, and see what happens. As my current winamps is verison 5.52

Edited: wait nevermind, I misread. it's at 5.572

~Faradey~, can you please post your code?

also, I don't think that it's related to winamps, it shows the titles perfectly in winamps. but what do i know? :P

and I also think this is a windows 7 problem. what os do you use?
pei
Posts: 7
Joined: April 6th, 2010, 1:23 am

Re: foreign languages not displaying

Post by pei »

sorry for double post. my edit button is gone. x.x

~Faradey~ did you use WindowMessagePlugin.dll?
User avatar
~Faradey~
Posts: 366
Joined: November 12th, 2009, 4:47 pm
Location: Ukraine

Re: foreign languages not displaying

Post by ~Faradey~ »

pei
~Faradey~ wrote:did you use WindowMessagePlugin.dll?
Sorry for late reply :|
Yes I've used WindowMessagePlugin.dll. And I cant post whole code now becouse it's not "standalone" and wouldn't work. It combined with others skins. But I can post
part of code. Simple as should be... And i use Windows 7. try saving config file as UTF-16 (little-endian, with BOM) or alse like kenz0 advised

Code: Select all

[MT]
Measure=Plugin
Plugin=Plugins\WindowMessagePlugin.dll
WindowClass=Winamp v1.x
Substitute="[Paused]":""," - Winamp":"","[Stopped]":"","[Приостановлено]":"-"," - Winamp":"","[Остановлено]":"=","Winamp ***":"**","WinAmp":""
UpdateDivider=2

[Track]
Meter=STRING
MeasureName=MT
X=0
Y=14
H=15
W=200
ClipString=1
FontColor=#FontColor#
FontFace=#Font#
;StringEffect=BORDER
FontSize=#Height#
StringAlign=LEFT
StringStyle=NORMAL
AntiAlias=1
pei
Posts: 7
Joined: April 6th, 2010, 1:23 am

Re: foreign languages not displaying

Post by pei »

~Faradey~ wrote:pei Sorry for late reply :|
Yes I've used WindowMessagePlugin.dll. And I cant post whole code now becouse it's not "standalone" and wouldn't work. It combined with others skins. But I can post
part of code. Simple as should be... And i use Windows 7. try saving config file as UTF-16 (little-endian, with BOM) or alse like kenz0 advised

Code: Select all

[MT]
Measure=Plugin
Plugin=Plugins\WindowMessagePlugin.dll
WindowClass=Winamp v1.x
Substitute="[Paused]":""," - Winamp":"","[Stopped]":"","[Приостановлено]":"-"," - Winamp":"","[Остановлено]":"=","Winamp ***":"**","WinAmp":""
UpdateDivider=2

[Track]
Meter=STRING
MeasureName=MT
X=0
Y=14
H=15
W=200
ClipString=1
FontColor=#FontColor#
FontFace=#Font#
;StringEffect=BORDER
FontSize=#Height#
StringAlign=LEFT
StringStyle=NORMAL
AntiAlias=1
how would i save the file as UTF-16? I'm using notepad. :3
User avatar
~Faradey~
Posts: 366
Joined: November 12th, 2009, 4:47 pm
Location: Ukraine

Re: foreign languages not displaying

Post by ~Faradey~ »

Well, you may try saving as UTF-8 with notepad. i dont know but it may solve problem
User avatar
Chewtoy
Moderator
Posts: 995
Joined: June 10th, 2009, 12:44 pm
Location: Sweden

Re: foreign languages not displaying

Post by Chewtoy »

pei wrote: how would i save the file as UTF-16? I'm using notepad. :3
"Save as..." and under what you want the file to be namned you have "Save as type" and "Encoding". Change the encoding (default ANSI) to "unicode big endian", as that is what was recomended.
I don't think, therefore I'm not.