It is currently September 20th, 2019, 1:01 pm

Need help with RSS feeder showing tag in info it dispays.

Help with creating, editing & fixing problems with skins
russnae
Posts: 4
Joined: August 5th, 2019, 1:03 am

Need help with RSS feeder showing tag in info it dispays.

russnae » August 5th, 2019, 1:47 am

Hello Everyone,

This is my first desktop made with rainmeter. All I did was use other people's skins and put them together. As I as still learning how to code a skin.

My problem is the RSS Feeder that I am using (Author=Ragingwasabi, link to download provided) shows the coding tags when it pulls back the info.(See image) I cant figure out how to stop it. I have looked over the documentation on Rainmeter website and followed those tutorials, but everything I do breaks the feeder. So short of completely coding my own, (which I have not done, yet.) I'm at a loss on how to fix it.

Any help would be great. Thank you.

I have changed the URL to parse espn's Rss. The orginal URL was Techcrunch and it had not problems with it. Everything showed like it was supposed to, when I changed the URL this happened (see image). Link to download=
desktopquestion.png
https://visualskins.com/skin/rss-feed-reader-pack
code ini file
problem.txt
You do not have the required permissions to view the files attached to this post.
User avatar
jsmorley
Developer
Posts: 19462
Joined: April 19th, 2009, 11:02 pm
Location: Fort Hunt, Virginia, USA

Re: Need help with RSS feeder showing tag in info it dispays.

jsmorley » August 5th, 2019, 1:58 am

I think if you add these lines:

RegexpSubstitute=1
Substitute="<!\[CDATA\[(.*)\]\]":"\1"

To each of the [RSS1] ... [RSS10] child measures, it might fix it for you.
User avatar
eclectic-tech
Rainmeter Sage
Posts: 3543
Joined: April 12th, 2012, 9:40 pm
Location: Cedar Point, Ohio, USA

Re: Need help with RSS feeder showing tag in info it dispays.

eclectic-tech » August 5th, 2019, 2:08 am

"Beaten by the 'Master' again..." ;-)

Edit the code by adding this line of code:

Code: Select all

Substitute="^\s+":"","<!\[CDATA\[":"","\]\]>":"","!\[CDATA\[":"","\]\]":""
to each section that return the "Title" information; that would be sections [RSS1] through [RSS10]. You do not need to add the line to the other webparser measures since they return a link.

This will substitute any instances of that text in the returned string.
You can find details in the RSS Tutorial in the documentation...
User avatar
jsmorley
Developer
Posts: 19462
Joined: April 19th, 2009, 11:02 pm
Location: Fort Hunt, Virginia, USA

Re: Need help with RSS feeder showing tag in info it dispays.

jsmorley » August 5th, 2019, 2:12 am

Wax on, wax off...
russnae
Posts: 4
Joined: August 5th, 2019, 1:03 am

Re: Need help with RSS feeder showing tag in info it dispays.

russnae » August 5th, 2019, 3:37 am

jsmorley wrote:
August 5th, 2019, 1:58 am
I think if you add these lines:

RegexpSubstitute=1
Substitute="<!\[CDATA\[(.*)\]\]":"\1"

To each of the [RSS1] ... [RSS10] child measures, it might fix it for you.
Thank you, this worked perfectly.
russnae
Posts: 4
Joined: August 5th, 2019, 1:03 am

Re: Need help with RSS feeder showing tag in info it dispays.

russnae » August 5th, 2019, 3:38 am

eclectic-tech wrote:
August 5th, 2019, 2:08 am
"Beaten by the 'Master' again..." ;-)

Edit the code by adding this line of code:

Code: Select all

Substitute="^\s+":"","<!\[CDATA\[":"","\]\]>":"","!\[CDATA\[":"","\]\]":""
to each section that return the "Title" information; that would be sections [RSS1] through [RSS10]. You do not need to add the line to the other webparser measures since they return a link.

This will substitute any instances of that text in the returned string.
You can find details in the RSS Tutorial in the documentation...
Thank you, I tried this but it didnt work. I appreciate the feed back and your help. Thank you very much.
russnae
Posts: 4
Joined: August 5th, 2019, 1:03 am

Re: Need help with RSS feeder showing tag in info it dispays.

russnae » August 5th, 2019, 3:41 am

Thank you guys for the help. Now I will try to code something of my own.?..........lol.
fixed.png
You do not have the required permissions to view the files attached to this post.