It is currently December 8th, 2021, 6:20 pm

Weather APP Trouble

General topics related to Rainmeter.
thaxela
Posts: 1
Joined: September 4th, 2009, 10:20 pm

Weather APP Trouble

Post by thaxela »

Hey everyone,

I'm trying to get the weather application to work, but i'm having immense trouble. If you could help me out that'd be great!

I'm using the Dark Rainmeter Skin (Located HERE which is using LocalWeather. In the .ini file it gives me a link to a weather location site, and tells me to enter my city's code to get the weather. All sounds fine and dandy. But when I go to the weather location site which is this one (takes a while to load and stuff) but when I enter my city, it doesnt give me a code. It's supposed to be a 5 digit code.

I live in Toronto, Ontario, Canada. If someone could help me with my problem or provide me with the weather code for Toronto, I would be incredibly thankful.

:)
User avatar
jsmorley
Developer
Posts: 22421
Joined: April 19th, 2009, 11:02 pm
Location: Fort Hunt, Virginia, USA

Re: Weather APP Trouble

Post by jsmorley »

thaxela wrote:Hey everyone,

I'm trying to get the weather application to work, but i'm having immense trouble. If you could help me out that'd be great!

I'm using the Dark Rainmeter Skin (Located HERE which is using LocalWeather. In the .ini file it gives me a link to a weather location site, and tells me to enter my city's code to get the weather. All sounds fine and dandy. But when I go to the weather location site which is this one (takes a while to load and stuff) but when I enter my city, it doesnt give me a code. It's supposed to be a 5 digit code.

I live in Toronto, Ontario, Canada. If someone could help me with my problem or provide me with the weather code for Toronto, I would be incredibly thankful.

:)
If you are being told to use that link you posted by the .ini, then you are NOT using the Dark_Rainmeter_III found HERE: You must be using some older version of Dark Rainmeter. Download the new one from the link you posted, and put it in place. It has the correct instructions in the LocalWeather.ini for getting your weather code for Yahoo/Weather.com. The old one used AccuWeather which I have moved away from.

Completely delete the folder for whatever Dark_Rainmeter you are using from the \Skins folder in My Documents\Rainmeter, then unzip the new one into \Skins. Then restart Rainmeter and it will be available to load using RainBrowser.

You should see some text like this in LocalWeather.ini

;=================================================
; Set these two variables for your location.
; In the United States, the code is your ZipCode.
; Outside the US, you can find your code at:
; http://www.weather.com/common/home/maps.html
; by entering your City, Country and using the
; code from the resulting URL.
; Example Glasgow, UK is UKXX0061
;
; Then set the desired "unit of measure".
; Unit=f for Fahrenheit, Unit=c for Celsius.
;=================================================
[Variables]
Location=22033
Unit=f

Do NOT just put a Yahoo / Weather.com location code in your old and busted AccuWeather version. It will chew off its own arm trying to escape. Get the correct Dark_Rainmeter_III and then put in the code.