It is currently July 7th, 2022, 3:55 am

Gadgets 7.3.0 - inspired by AddGadgets.com Sidebar Gadgets

A package of skins with a "theme" or by a single author
User avatar
SilverAzide
Rainmeter Sage
Posts: 1929
Joined: March 23rd, 2015, 5:26 pm

Re: Gadgets 7.1.1 - inspired by AddGadgets.com Sidebar Gadgets

Post by SilverAzide »

jsmorley wrote: January 10th, 2022, 8:49 pm I think you will find that if you change the API Key to 21d8a80b3d6b444998a80b3d6b1449d3, it will begin to work again.
I noticed that too! That does seem to work... for today, at least!
Gadgets Wiki GitHub More Gadgets...
User avatar
SilverAzide
Rainmeter Sage
Posts: 1929
Joined: March 23rd, 2015, 5:26 pm

Re: Gadgets 7.2.0 - inspired by AddGadgets.com Sidebar Gadgets

Post by SilverAzide »

A major update to the Gadgets has been released!

Big thanks to Github users RacerXNFS and excesseve for their help debugging and enhancing the CPU Meter to work with AMD Threadripper CPUs!

7.2.0 - 2022-01-10
  • Updated Weather Meter to work with latest weather.com API changes.
  • Corrected "non-Pro" Network Meter and Wireless Meter issue where current session statistics were the same as the total values.
  • Updated all Network Meters and Wireless Meters to show Wi-Fi signal strength in the Wireless Networks tooltip.
  • Corrected NetMonitor issue where no network activity would be reported for adapters with duplicate (invalid) names. (Upgrading the service is recommended.)
  • Corrected All CPU Meter for issue where cores were not shown properly on machines with multiple processor groups (i.e., more than 64 threads). (Thanks excesseve!)
  • Enhanced All CPU Meter to add option to select which application is called when double-clicking the skin (Task Manager or Resource Monitor).
  • Enhanced ActiveNet plugin to add CpuGroups to return the number of processor groups per machine.
* Requires Rainmeter 4.5.7 or later.

NOTE for those who use the Network Meter Pro and Wireless Meter Pro skin variants: The NetMonitor service has been updated in this release. Upgrading the service is recommended. To upgrade, use the Network Settings to stop the service, uninstall it, and then reinstall.
Gadgets Wiki GitHub More Gadgets...
APK17
Posts: 8
Joined: June 21st, 2021, 11:39 pm

Re: Gadgets 7.2.0 - inspired by AddGadgets.com Sidebar Gadgets

Post by APK17 »

On the first two machines I've updated to 7.2 the sensor ID customizations in HWiNFO.inc seem to have been lost. :(
User avatar
SilverAzide
Rainmeter Sage
Posts: 1929
Joined: March 23rd, 2015, 5:26 pm

Re: Gadgets 7.2.0 - inspired by AddGadgets.com Sidebar Gadgets

Post by SilverAzide »

APK17 wrote: January 10th, 2022, 10:33 pm On the first two machines I've updated to 7.2 the sensor ID customizations in HWiNFO.inc seem to have been lost. :(
Oh CRAP! I'll fix the release... Thanks for the info! (Check your @Backup folder for your original settings)
Gadgets Wiki GitHub More Gadgets...
User avatar
SilverAzide
Rainmeter Sage
Posts: 1929
Joined: March 23rd, 2015, 5:26 pm

Re: Gadgets 7.2.0 - inspired by AddGadgets.com Sidebar Gadgets

Post by SilverAzide »

APK17 wrote: January 10th, 2022, 10:33 pm On the first two machines I've updated to 7.2 the sensor ID customizations in HWiNFO.inc seem to have been lost. :(
HUGE apologies and very sorry for any inconvenience. I've corrected the .rmskin file and re-posted it.
Gadgets Wiki GitHub More Gadgets...
APK17
Posts: 8
Joined: June 21st, 2021, 11:39 pm

Re: Gadgets 7.2.0 - inspired by AddGadgets.com Sidebar Gadgets

Post by APK17 »

SilverAzide wrote: January 10th, 2022, 10:54 pm HUGE apologies and very sorry for any inconvenience. I've corrected the .rmskin file and re-posted it.
No problem. Glad I could help catch something. No issues with simply taking the file out of the backup folder and overwriting the "new" file?
User avatar
SilverAzide
Rainmeter Sage
Posts: 1929
Joined: March 23rd, 2015, 5:26 pm

Re: Gadgets 7.2.0 - inspired by AddGadgets.com Sidebar Gadgets

Post by SilverAzide »

APK17 wrote: January 10th, 2022, 10:56 pm No problem. Glad I could help catch something. No issues with simply taking the file out of the backup folder and overwriting the "new" file?
You'll be better off copying the entire contents of the @Backup\Gadgets folder over your installation. This will ensure all the skins are back the way you configured them, not just the HWiNFO settings.
Gadgets Wiki GitHub More Gadgets...
Tyjen
Posts: 2
Joined: January 11th, 2022, 11:49 am

Re: Gadgets 7.2.0 - inspired by AddGadgets.com Sidebar Gadgets

Post by Tyjen »

I'm new to this forum and have been using these gadgets for many years, with no issue. Over the last few updates for both Rainmeter and Gadgets, I lost the ability to use the "list HWiFO Indexes" and Edit HWiNFO Settings". With my mouse over the text, the mouse and the text actively change to show the text is Hyperlink. Yet I cannot get the action to occur that opens either HWiNFO shared setting or the skin settings.

I'm currently using Gadgets v7.2.0, Reainmeter v4.5.8, HWiNFO v7.16, and I'm on windows 11 latest update.

The issue may be a windows 11 thing, I'm not sure. Since the issue has been going on for a while, I have gone through several version updates for all apps concerned. And yes, I have un-installed and re-installed all apps to no avail. I should note that the last time I really made changes, and all was good, I was on windows 10.

I have just tried "Rainformer HWiNFO edition" and on the settings general page there is the hyperlink for opening HWiNFO, noted as "Open HWiNFO SMW" and it works. This leaves me confused as this skin works as required.

I'm just looking for help/ ideas to rectify this issue. Thank you, in advance.

Tyjen.
User avatar
SilverAzide
Rainmeter Sage
Posts: 1929
Joined: March 23rd, 2015, 5:26 pm

Re: Gadgets 7.2.0 - inspired by AddGadgets.com Sidebar Gadgets

Post by SilverAzide »

Tyjen wrote: January 11th, 2022, 12:23 pm I'm new to this forum and have been using these gadgets for many years, with no issue. Over the last few updates for both Rainmeter and Gadgets, I lost the ability to use the "list HWiFO Indexes" and Edit HWiNFO Settings". With my mouse over the text, the mouse and the text actively change to show the text is Hyperlink. Yet I cannot get the action to occur that opens either HWiNFO shared setting or the skin settings.

I'm currently using Gadgets v7.2.0, Reainmeter v4.5.8, HWiNFO v7.16, and I'm on windows 11 latest update.

The issue may be a windows 11 thing, I'm not sure. Since the issue has been going on for a while, I have gone through several version updates for all apps concerned. And yes, I have un-installed and re-installed all apps to no avail. I should note that the last time I really made changes, and all was good, I was on windows 10.

I have just tried "Rainformer HWiNFO edition" and on the settings general page there is the hyperlink for opening HWiNFO, noted as "Open HWiNFO SMW" and it works. This leaves me confused as this skin works as required.

I'm just looking for help/ ideas to rectify this issue. Thank you, in advance.

Tyjen.
Sorry you are having issues! Those two particular links ("List HWiNFO Indexes" and "Edit HWiNFO Settings") simply invoke another program.

You might want to check the Rainmeter log to see what is happening on your machine. To do that, right-click the Rainmeter icon in your system tray and select the About option. There is a Log tab on the dialog(the default tab). You can open the log, then click the links that aren't working for you to see if any errors pop up.

Depending on your system (i.e., you are using a locked down machine in which you are not an Administrator use), you might have issues related to security. Specifically, the "List HWiNFO Indexes" option dumps the contents of the HWiNFO registry, parses the data, and displays it in Notepad (or whatever your preferred editor is).

Secondly, the "Edit HWiNFO Settings" command simply runs Notepad (or your preferred editor) and opens the file where you can set the values needed (as listed in the first step).

You'll note that both commands involve opening your text editor and both are failing, which leads me to believe you might have misconfigured something. By default, Rainmeter opens Notepad to edit things, but you can change this to a different editor. If you open the Rainmeter Manage dialog and go to the Settings tab, check to see that the Editor option is blank, or contains the correct path of a text editor. If you installed Notepad++, changed Rainmeter to point to it, then (on your new machine) didn't install Notepad++ (or installed it in a different place), then Rainmeter will be trying to run a program that doesn't exist and failing.

Check the log and this option and let me know how it goes.
Gadgets Wiki GitHub More Gadgets...
AtmaDarkwolf
Posts: 30
Joined: October 24th, 2021, 3:37 am

Re: Gadgets 7.2.0 - inspired by AddGadgets.com Sidebar Gadgets

Post by AtmaDarkwolf »

So I'm betting your sick of seeing my user name pop up with new and interesting issues :D

That being said, I have a new issue that I am unsure is rainmeter, gadget, or TAN window manager related (TAN will save locations of programs and I can reset positions quickly without having to drag and drop / resize windows each time) but the issue only popped up sometime after the most recent rainmeter update and the recent issues with weather meter losing connection, or the update to fix said issue. (I only noticed it today when I had to reset windows after I moved one) -

Now it will put all the gadgets back to their proper locations, except the clock I made and the clipboard meter(which if u remember from before, I had to edit myself to make it look like the others in the suite, since the options to change its background/edges/etc. (I had to go in and just toggle the setting myself) - Except those two it sends to random spots elsewhere (never to same spot) on either monitor. (And the clipboard meter will often pop back to where it belongs, but the clock never does) - I can go into rainmeter and activate one of the saved layouts and it goes back to proper places, but that is extra mouse clicks I'd prefer to avoid if possible.

On top of this, the clipboard skin does not appear in the list (the one from the old modern gadgets does, but the new one that is the added extra for this suite does not) so I cannot even be sure I am using the new or old meter.

Anyways just put this here hoping someone can point to where to look as to why this is happening, but I am pretty sure its TAN related (just hoping it is not since I doubt that the author of TAN is even around anymore)

Edit, nvm about clipboard meter not showing up, it was utterly gone, just re-downloaded and added it again now, seems to work, but had to redo all settings as before again.

Edit v.2 : *Sigh* Nvm the 'new' clipboard meter does not work, only shows clipboard items made BEFORE I add the skin. Anything copied afterwards does not get added, unless the old moderngadgets clipboard meter is ALSO running.