It is currently December 6th, 2022, 1:53 pm

!SetOption Not working

Get help with creating, editing & fixing problems with skins
User avatar
balala
Rainmeter Sage
Posts: 14766
Joined: October 11th, 2010, 6:27 pm
Location: Gheorgheni, Romania

Re: !SetOption Not working

Post by balala »

Jaime Méndez wrote: September 28th, 2022, 6:26 pm The part of the code with the problem begins in line 156 of EXpandable.ini file
Just remove the empty CheckName= variable from the [Variables] section of the EXpandable.ini file.
This is not needed because the CheckName variable is declared into the [Variables] section of the @Resources\ExpandVariables.inc file, which is included into the skin, with the @include=#@#ExpandVariables.inc option. The !WriteKeyValue bangs write the variable there, into the included file, not to the main EXpandable.ini file. Having an empty same-named variable in the main file, prevents the skin to use the correctly written variable from the included file.
User avatar
Jaime Méndez
Posts: 91
Joined: August 31st, 2022, 10:00 pm

Re: !SetOption Not working

Post by Jaime Méndez »

It is working know :D Thanks a lot :thumbup:

I still have a problem though. When hiding explorer after some navigation, EXpandable folder doesn't show its name until i middle click it
User avatar
balala
Rainmeter Sage
Posts: 14766
Joined: October 11th, 2010, 6:27 pm
Location: Gheorgheni, Romania

Re: !SetOption Not working

Post by balala »

Jaime Méndez wrote: September 28th, 2022, 7:42 pm I still have a problem though. When hiding explorer after some navigation, EXpandable folder doesn't show its name until i middle click it
Not sure I follow. When launching the skin, it shows a folder. When hovering the mouse over it, its content is revealed. When I middle-click to one of those folders, it opens. I get the name of the opened folder every time. Don't you get it?
User avatar
Jaime Méndez
Posts: 91
Joined: August 31st, 2022, 10:00 pm

Re: !SetOption Not working

Post by Jaime Méndez »

You can open an explorer clicking in the box beside the expandable folder. This little box is situated in the upper left corner of the skin. Once you have the explorer shown you can navigate through files and folders but when you hide the explorer again, expandable folder shows again but without name folder from the las directory you left the explorer. You need to middle click de folder so it can start showing its name. It should show it automaticly the first time
User avatar
balala
Rainmeter Sage
Posts: 14766
Joined: October 11th, 2010, 6:27 pm
Location: Gheorgheni, Romania

Re: !SetOption Not working

Post by balala »

Jaime Méndez wrote: September 28th, 2022, 8:15 pm You can open an explorer clicking in the box beside the expandable folder. This little box is situated in the upper left corner of the skin. Once you have the explorer shown you can navigate through files and folders but when you hide the explorer again, expandable folder shows again but without name folder from the las directory you left the explorer. You need to middle click de folder so it can start showing its name. It should show it automaticly the first time
Alright, now I get it. I see the issue. Unfortunately I don't work anymore this evening, because here is almost midnight. If no one helps, tomorrow I'm gonna try to figure out what's goin gon.
Sorry...
User avatar
Jaime Méndez
Posts: 91
Joined: August 31st, 2022, 10:00 pm

Re: !SetOption Not working

Post by Jaime Méndez »

Thank you, I appreciate your help :)
User avatar
balala
Rainmeter Sage
Posts: 14766
Joined: October 11th, 2010, 6:27 pm
Location: Gheorgheni, Romania

Re: !SetOption Not working

Post by balala »

Jaime Méndez wrote: September 28th, 2022, 8:15 pm You can open an explorer clicking in the box beside the expandable folder. This little box is situated in the upper left corner of the skin. Once you have the explorer shown you can navigate through files and folders but when you hide the explorer again, expandable folder shows again but without name folder from the las directory you left the explorer. You need to middle click de folder so it can start showing its name. It should show it automaticly the first time
Try putting back the commented out DynamicVariables=1 option on the [MeasurePathFolderNameR] measure, located into the EXpandable\EXpandable.ini file. Do you get it working with this modification?
User avatar
Jaime Méndez
Posts: 91
Joined: August 31st, 2022, 10:00 pm

Re: !SetOption Not working

Post by Jaime Méndez »

It is working now! :beer: Thank you

I am already finishing it, it is almost done. Setting some buttons here and there :D
I will post it as a new mode merged skins from other two authors
User avatar
balala
Rainmeter Sage
Posts: 14766
Joined: October 11th, 2010, 6:27 pm
Location: Gheorgheni, Romania

Re: !SetOption Not working

Post by balala »

Jaime Méndez wrote: September 29th, 2022, 6:26 pm It is working now!
I'm glad. :thumbup:
Jaime Méndez wrote: September 29th, 2022, 6:26 pm I am already finishing it, it is almost done. Setting some buttons here and there :D
I will post it as a new mode merged skins from other two authors
Ok, post the skin when is ready.