It is currently November 28th, 2022, 3:23 pm

4.5.14.3663

Test and provide feedback on potential changes
User avatar
jsmorley
Developer
Posts: 22551
Joined: April 19th, 2009, 11:02 pm
Location: Fort Hunt, Virginia, USA

4.5.14.3663

Post by jsmorley »

We have several bug fixes and changes that we would like to get tested out a bit before we do a release in the next day or two!

The build is at: https://builds.rainmeter.net/test_builds/Rainmeter-4.5.14.3663-prerelease.exe

Changes:
  • Languages: Updated all language files
  • Languages: Updated Turkish
  • Languages: Updated Dutch
  • Languages: Updated Danish
  • Languages: Updated Romanian
  • Languages: Updated ChineseSimplified and ChineseTraditional
  • Languages: Updated Slovak
  • Languages: Updated German
  • Languages: Updated French
  • Languages: Finish and improve Malay translation (Issue #299)
    Submitted by user @amsyarzero

  • Lua: Allow the Update function to return 2 values (number and string)
    Note: Return order doesn't matter
    Suggested by user @deathcrafter
  • Rainmeter: Fixed a typo in Internet.cpp (Issue #306)
    Submitted by user @redstarbird
  • String meter/Inline shadow: Treat the shadow drawing surface as the size of the meter itself instead of using the underlying bitmap of the skin's bounds (in case SkinWidth/Height is truncating the drawing of the meter)
  • C# Plugins: Use latest ilasm.exe in DLLExporter (Issue #310)
    Use TargetDotNetFrameworkVersion.VersionLatest instead of TargetDotNetFrameworkVersion.Version20 to find ilasm.exe. This fixes assembly errors
    when using latest .NET Framework libraries in your plugin.
    Submitted by user @deathcrafter
  • Rainmeter.ini: Add an extra empty line before appending a new section at the end of the settings file. Note: This is for newly added sections, not existing sections
  • Rainmeter: Convert font enumeration from Gdiplus to DirectWrite
    Note: This is just for logging purposes and does not change any font loading for the String meter. In general, this will log more font families since
    font faces will now be included in the list. Also: In debug mode, this will also enumerate any fonts loaded with LocalFont and the fonts in
    "@Resources\Fonts" folder when a skin loads. This will help skin authors find the correct font name to use with the FontFace option.
  • MathParser: Increased base conversion limitations
    https://forum.rainmeter.net/viewtopic.php?t=41135#p209189
  • Dialogs: Fix icon loading
    https://forum.rainmeter.net/viewtopic.php?t=41131
  • GameMode: Tweak the logic when Rainmeter exits while in game mode
    https://forum.rainmeter.net/viewtopic.php?t=41099
  • SkinInstaller: Adjust the enabled/disabled state of some GUI elements
    The "Load included layout" / "Load included skins" checkbox will now become disabled and unchecked if the entire group (Skins or Layouts) is unchecked. This prevents the attempted loading of a non-installed skin/layout once Rainmeter re-starts. Note: The last checked state of the "Load included layout" / "Load included skins" checkbox will be remembered in case any of the Skins/Layout groups checkboxes get enabled again. This "remembering" only happens while the SkinInstaller is open, and is NOT persistent. The "Install" button will now be disabled if all items in the list are unchecked.
  • Skin: Fixed issue where the incorrect monitor was selected when using the monitor flag on WindowY only (not defined on WindowX)
    https://forum.rainmeter.net/viewtopic.php?t=40881
  • GeneralImage: Fixed "ImageCrop" formula parsing
    https://forum.rainmeter.net/viewtopic.php?t=40682#p207510
  • Rainmeter: Fixed bug with random number generators
User avatar
SilverAzide
Rainmeter Sage
Posts: 2174
Joined: March 23rd, 2015, 5:26 pm

Re: 4.5.15.3653

Post by SilverAzide »

Whoops... Something seems broken with Image meters where the ImageCrop option is used. It looks like all the frames are being semi-sorta-rendered on top of each other. Note the battery icon...

Before (4.5.13):
Before.png
After (4.5.15):
After.png
In case it helps, a snippet of the affected code looks like this:

Code: Select all

[MeterBatteryIcon]
Meter=Image
ImageName="#@#Battery.png"
ImageCrop=(34 * #BatteryFrame#),0,34,34,1
...
Finally, just curious... what happened to 3.5.14?
You do not have the required permissions to view the files attached to this post.
Gadgets Wiki GitHub More Gadgets...
User avatar
Brian
Developer
Posts: 2535
Joined: November 24th, 2011, 1:42 am
Location: Utah

Re: 4.5.15.3653

Post by Brian »

SilverAzide wrote: September 1st, 2022, 9:45 pm Whoops... Something seems broken with Image meters where the ImageCrop option is used. It looks like all the frames are being semi-sorta-rendered on top of each other. Note the battery icon...
Whoops, I forgot to add the left to the right, and the top to the bottom. You can see it here.

Fixed. Thanks for the quick testing!


SilverAzide wrote: September 1st, 2022, 9:45 pm Finally, just curious... what happened to 3.5.14?
It's here, but just before we were to do the forum pre-release, I made a last minute change to the inline shadow issue, so we just bumped the version again. I am not sure if we will bump it again when we do a real release, or go back to 3.5.14 since this was just a pre-release.

-Brian
User avatar
jsmorley
Developer
Posts: 22551
Joined: April 19th, 2009, 11:02 pm
Location: Fort Hunt, Virginia, USA

Re: 4.5.14.3656

Post by jsmorley »

My bad... I have done a new build with the ImageCrop fix in the first post, and it will be version 4.5.14.3656
nek
Posts: 77
Joined: November 3rd, 2019, 12:00 am

Re: 4.5.14.3656

Post by nek »

No issues.
Thank you for making the Rainmeter application great.

Code: Select all

Rainmeter 4.5.14.3656 (64-bit)
Language: Japanese (1041)
Build time: 2022-09-01 20:16:56
Windows 10 Pro 2009 64-bit (build 19043) - Japanese (1041)
Path: Z:\Apps\Rainmeter\
SkinPath: Z:\Apps\Rainmeter\Skins\
SettingsPath: Z:\Apps\Rainmeter\
IniFile: Z:\Apps\Rainmeter\Rainmeter.ini
User avatar
death.crafter
Rainmeter Sage
Posts: 1398
Joined: April 24th, 2021, 8:13 pm

Re: 4.5.14.3656

Post by death.crafter »

Should I update the example plugins repo and submit a pr? This includes updating all the plugins to use VS 2022 and .NET Framework 4.7.1 by default. And the DLLExporter ofc.
from the Realm of Death
User avatar
Brian
Developer
Posts: 2535
Joined: November 24th, 2011, 1:42 am
Location: Utah

Re: 4.5.14.3656

Post by Brian »

If you want. I just haven't gotten around to it yet.

-Brian
User avatar
death.crafter
Rainmeter Sage
Posts: 1398
Joined: April 24th, 2021, 8:13 pm

Re: 4.5.14.3656

Post by death.crafter »

Brian wrote: September 2nd, 2022, 7:33 am If you want. I just haven't gotten around to it yet.

-Brian
I was looking for it, and windows 7 actually supports .NET Framework up to 4.8, instead of 4.7.1 as you previously noted. But only .NET Framework 3.5 and lower come preinstalled with Windows 7. reference

So, do you think it might be better if we consider currently used framework version in DLLExporter to correctly determine the ilasm path instead?
from the Realm of Death
User avatar
jsmorley
Developer
Posts: 22551
Joined: April 19th, 2009, 11:02 pm
Location: Fort Hunt, Virginia, USA

Re: 4.5.14.3656

Post by jsmorley »

death.crafter wrote: September 2nd, 2022, 7:29 am Should I update the example plugins repo and submit a pr? This includes updating all the plugins to use VS 2022 and .NET Framework 4.7.1 by default. And the DLLExporter ofc.
I think this would be very helpful!
User avatar
Brian
Developer
Posts: 2535
Joined: November 24th, 2011, 1:42 am
Location: Utah

Re: 4.5.14.3656

Post by Brian »

death.crafter wrote: September 2nd, 2022, 7:49 am I was looking for it, and windows 7 actually supports .NET Framework up to 4.8, instead of 4.7.1 as you previously noted. But only .NET Framework 3.5 and lower come preinstalled with Windows 7. reference

So, do you think it might be better if we consider currently used framework version in DLLExporter to correctly determine the ilasm path instead?
Hmmm. A while back when I downloaded Windows 7 to use in a VM, it already came pre-installed with 4.7.1, but not 4.8. Maybe they did some sort of "roll up" to include this version in when downloaded. Or maybe some software I installed on the VM placed it there. :confused:

Anyway, let's go with 4.7.1 for now, since I changed all the projects to use that. We've only had the one issue, I believe.

To be honest with you, we will be dropping Windows 7 (and maybe 8 and 8.1) support in the near future, so we can go through this exercise all over again when that happens.

-Brian