It is currently December 10th, 2018, 8:50 pm

Fountain of Colors visualizer suddenly stop working.

Help with creating, editing & fixing problems with skins
TangyLemon
Posts: 9
Joined: January 16th, 2018, 9:55 pm

Re: Fountain of Colors visualizer suddenly stop working.

TangyLemon » January 23rd, 2018, 9:04 pm

eclectic-tech wrote:The line I highlighted in RED tells me you are not able to create an audio stream for the AudioLevel plugin...
I use the Nahimic 2+ Audio Driver however I disabled it be following the guide below, however, I did that a while ago and Fountain of Colors still does not work.
https://msdn.microsoft.com/en-us/library/windows/desktop/dd370844(v=vs.85).aspx
Is it possible to reinstall Rainmeter to fix the AudioLevel plugin?
If they worked a while ago, then something has changed on your PC and is preventing the plugin from creating an audio stream. Until you disable exclusive mode, no visualizer will work.
Before when I first got FoC the visaulizer did not work but one day I loaded it up again and it worked. Then after I shut down my computer and the next day I turned on my computer and launched Rainmeter. After that FoC did not work again.
Have you found any visualizer that works?
I have tried the Rainy Days visualizer https://alatsombath.deviantart.com/art/Rainy-Days-desktop-music-visualizer-519515704
And the Monstercat Visualizer https://marcopixel.deviantart.com/art/Monstercat-Visualizer-for-Rainmeter-486330771
However both did not work.
User avatar
balala
Rainmeter Sage
Posts: 7152
Joined: October 11th, 2010, 6:27 pm
Location: Gheorgheni, Romania

Re: Fountain of Colors visualizer suddenly stop working.

balala » January 23rd, 2018, 9:19 pm

arty_fish wrote:Have you tried re-installing rainmeter - in-case there's a problem with the Audio Level plugin itself?
In most cases this doesn't help.
I think users should not continuously reinstall Rainmeter. In my opinion this rarely, or even never help.
User avatar
eclectic-tech
Rainmeter Sage
Posts: 3050
Joined: April 12th, 2012, 9:40 pm
Location: Cedar Point, Ohio, USA

Re: Fountain of Colors visualizer suddenly stop working.

eclectic-tech » January 23rd, 2018, 10:07 pm

TangyLemon wrote:I use the Nahimic 2+ Audio Driver however I disabled it be following the guide below, however, I did that a while ago and Fountain of Colors still does not work.
https://msdn.microsoft.com/en-us/library/windows/desktop/dd370844(v=vs.85).aspx
Is it possible to reinstall Rainmeter to fix the AudioLevel plugin?
I have seen that changing the settings in Windows Audio Properties to not allow exclusive mode, does not always work. On re-starting those audio "enhancement" programs will take exclusive control again, because that is what they need to "enhance" all of your sounds. :17nodding

Removing those programs is the only option I have heard that works to get visualizers working.

As you have found out, no visualizer is going to work as long as you have Nahamic running on your system. :17denial

balala is correct, in this case, and most cases, re-installing Rainmeter is not going to help.

I would remove Nahamic, but that is your decision. As long as it is running forget about reliable visualizer use... :17flag
arty_fish
Posts: 14
Joined: June 7th, 2016, 7:04 am

Re: Fountain of Colors visualizer suddenly stop working.

arty_fish » January 24th, 2018, 12:08 am

no visualizer is going to work as long as you have Nahamic running on your system
eclectic-tech,

My logic is:

1. Disable nahimic from startup

2. Switch source output to DirectSound (in my experience rainmeter visualizers flat out won't work with wasapi due to the limitations of the audiolevel plugin)

3. If still not working, consider that the audiolevel plugin needs 'refreshing'.

Are you saying that nahimic interferes with system audio even if it's disabled at start up? I admit to no experience of it, but I would have thought an onboard codec (such as a realtek) would invoke instead.
User avatar
eclectic-tech
Rainmeter Sage
Posts: 3050
Joined: April 12th, 2012, 9:40 pm
Location: Cedar Point, Ohio, USA

Re: Fountain of Colors visualizer suddenly stop working.

eclectic-tech » January 24th, 2018, 1:29 am

arty_fish wrote:eclectic-tech,

My logic is:

1. Disable nahimic from startup

2. Switch source output to DirectSound (in my experience rainmeter visualizers flat out won't work with wasapi due to the limitations of the audiolevel plugin)

3. If still not working, consider that the audiolevel plugin needs 'refreshing'.

Are you saying that nahimic interferes with system audio even if it's disabled at start up? I admit to no experience of it, but I would have thought an onboard codec (such as a realtek) would invoke instead.
Thanks for the info arty_fish!

I do not have Nahamic on my system, so my experience has only been from user who had Nahamic and corrected visualizer issues by uninstalling; perhaps they did not know how to disable it at startup. :confused:

Your first hand experience may be more helpful! :thumbup:
TangyLemon
Posts: 9
Joined: January 16th, 2018, 9:55 pm

Re: Fountain of Colors visualizer suddenly stop working.

TangyLemon » January 24th, 2018, 7:56 pm

arty_fish wrote:eclectic-tech,

My logic is:

1. Disable nahimic from startup

2. Switch source output to DirectSound (in my experience rainmeter visualizers flat out won't work with wasapi due to the limitations of the audiolevel plugin)

3. If still not working, consider that the audiolevel plugin needs 'refreshing'.

Are you saying that nahimic interferes with system audio even if it's disabled at start up? I admit to no experience of it, but I would have thought an onboard codec (such as a realtek) would invoke instead.
Thank you very much arty_fish! That solved the problem.
And also thank you balala and eclectic-tech for trying to help me fix the problem!
User avatar
balala
Rainmeter Sage
Posts: 7152
Joined: October 11th, 2010, 6:27 pm
Location: Gheorgheni, Romania

Re: Fountain of Colors visualizer suddenly stop working.

balala » January 24th, 2018, 8:12 pm

TangyLemon wrote:And also thank you balala and eclectic-tech for trying to help me fix the problem!
From my part, I'm glad to help and glad if you got it working.
User avatar
eclectic-tech
Rainmeter Sage
Posts: 3050
Joined: April 12th, 2012, 9:40 pm
Location: Cedar Point, Ohio, USA

Re: Fountain of Colors visualizer suddenly stop working.

eclectic-tech » January 25th, 2018, 2:09 am

Excellent TangyLemon! :great: Glad you finally got things working again, thanks to arty_fish's input! :thumbup:
User avatar
AlyxIce
Posts: 1
Joined: July 11th, 2018, 12:48 pm

Re: Fountain of Colors visualizer suddenly stop working.

AlyxIce » July 11th, 2018, 12:53 pm

I am using MSI and I do have Nahimic, but I did disable it. I also reinstalled rainmeter and all my audio device drivers and updated them. I have no idea how, when or why all of my sound visualizers stopped working. I didn't even notice when it happened, I am sure I did not change any of my system or Rainmeter settings. I have found someone with the exact same problem that they (probably) resolved by updating their audio device drivers, which did not work for me. :uhuh:

DBUG (14:55:33.451) : Releasing audio device.
WARN (14:55:34.943) : Failed to initialize audio client.
DBUG (14:55:34.946) : Releasing dummy stream audio device.
DBUG (14:55:34.952) : Releasing audio device.
WARN (14:55:36.477) : Failed to initialize audio client.
DBUG (14:55:36.481) : Releasing dummy stream audio device.
DBUG (14:55:36.486) : Releasing audio device.
WARN (14:55:37.985) : Failed to initialize audio client.
DBUG (14:55:37.986) : Releasing dummy stream audio device.
DBUG (14:55:37.993) : Releasing audio device.
WARN (14:55:39.491) : Failed to initialize audio client.
DBUG (14:55:39.495) : Releasing dummy stream audio device.
DBUG (14:55:39.500) : Releasing audio device.
User avatar
eclectic-tech
Rainmeter Sage
Posts: 3050
Joined: April 12th, 2012, 9:40 pm
Location: Cedar Point, Ohio, USA

Re: Fountain of Colors visualizer suddenly stop working.

eclectic-tech » July 11th, 2018, 9:41 pm

The "Failed to initialize audio client" error is caused by something on your system handling the audio in exclusive mode, not allowing any other process to have any control

This can be any sound enhancement programs such as Nahamic, Sonic, etc.
Did you disable Nahamic in startup (it starts automatically on system re-boots otherwise)

According to arty_fish rainmeter visualizers flat out won't work with WASAPI

Also make sure you do not allowing devices to operate in "exclusive mode" in Windows sound device settings

Hope some of this helps... :17flag