It is currently September 21st, 2019, 6:13 pm

Need help regarding gmail skins

Help with creating, editing & fixing problems with skins
User avatar
Kaelri
Developer
Posts: 1739
Joined: July 25th, 2009, 4:47 am

Re: Need help regarding gmail skins

Kaelri » December 19th, 2010, 1:26 am

I give up. I can't reproduce your problem; I can't even offer a theoretical explanation for it. I can suggest a complete uninstall-and-reinstall of Rainmeter, but that's just standard procedure in the event of a catastrophic, irreparable error. Congratulations, my friend, you've beaten us.
Chaoz
Posts: 19
Joined: May 28th, 2009, 12:15 am

Re: Need help regarding gmail skins

Chaoz » December 19th, 2010, 6:11 am

Even a reinstall didn't work. Guess me and gmail just wasn't meant to be.
User avatar
Chewtoy
Moderator
Posts: 1010
Joined: June 10th, 2009, 12:44 pm
Location: Sweden

Re: Need help regarding gmail skins

Chewtoy » December 19th, 2010, 11:08 am

Chaoz wrote:Even a reinstall didn't work. Guess me and gmail just wasn't meant to be.
Correction: You and TWO gmail accounts weren't meant to be.
I don't think, therefore I'm not.
daplon
Posts: 2
Joined: March 8th, 2019, 7:23 pm

Re: Need help regarding gmail skins

daplon » March 8th, 2019, 7:39 pm

Hi,

Old post but I'm having the same issue.

I have 2 gmail accounts in 2 skins, really they are the same skin, only change de users and passwords. They worked perfectly until a few days... now the 2 skins shows the unread emails of the second account.

I have debug = 2 in the skin 1 and when i saw it, the skin 1 url, dont work, and redirects to the url of the second account ever.

I think the problem are the PROFILES in Chrome, i have 2 created.


If i open my profile 1 in Chrome:

- I go to https://User1:Pass1@gmail.google.com/gmail/feed/atom it goes to https://mail.google.com/mail/u/0/feed/atom and show the correct XML to parse.

If i open my profile 2 in Chrome:

- I go to https://User2:Pass2@gmail.google.com/gmail/feed/atom it goes to https://mail.google.com/mail/u/0/feed/atom and show the correct XML to parse.

Conclusion: They go to the same url --> https://mail.google.com/mail/u/0/feed/atom

So... ¿how the skin knows what account results to show? It appears that now It depends of the profile. The skins only shows the results of the second profile.

¿Can I specify the profile in the Url parameter of the skin?


Any solution for this?


¡¡¡ Thanks for answers !!!

PD: Sorry by my English, I'm spanish.
User avatar
balala
Rainmeter Sage
Posts: 8634
Joined: October 11th, 2010, 6:27 pm
Location: Gheorgheni, Romania

Re: Need help regarding gmail skins

balala » March 8th, 2019, 8:15 pm

daplon wrote:
March 8th, 2019, 7:39 pm
So... ¿how the skin knows what account results to show?
Based on the username and password provided through the URL. I'm not sure what to say, I'm checking mine two accounts as well and my skins are working well, showing the new emails in both accounts, distinctly.
So, first please pack the skins (both) and upload the package, to can check. Take care to remove the passwords from the appropriate files, before packing them.
daplon
Posts: 2
Joined: March 8th, 2019, 7:23 pm

Re: Need help regarding gmail skins

daplon » March 9th, 2019, 8:21 am

First, very thanks for answer.
balala wrote:
March 8th, 2019, 8:15 pm
Based on the username and password provided through the URL
Yeah, but if I put wrong user or password, it still works :? (ever with unread emails of the second account) so I supposed the problem is the url or cache...

Just enter in the forum to say that i Solve It :D

I have change the url in the skins from :

Url=https://#User#:#Pass#@gmail.google.com/gmail/feed/atom

To:

Url=https://#User#%40gmail.com:#Pass#@mail.google.com/a/gmail.com/feed/atom/

I read that in other post of the forum.

¡¡¡ And it works !!!

Maybe that can help others with similar problems.
User avatar
balala
Rainmeter Sage
Posts: 8634
Joined: October 11th, 2010, 6:27 pm
Location: Gheorgheni, Romania

Re: Need help regarding gmail skins

balala » March 9th, 2019, 11:09 am

daplon wrote:
March 9th, 2019, 8:21 am
¡¡¡ And it works !!!

Maybe that can help others with similar problems.
:thumbup: