It is currently October 26th, 2021, 12:29 pm

[Solved] Drive Label not showing (SD Card)

Help with creating, editing & fixing problems with skins
pixlplague
Posts: 4
Joined: August 11th, 2021, 11:59 am

Re: Drive Label not showing (SD Card)

Post by pixlplague »

jsmorley wrote: August 14th, 2021, 4:11 pm I wonder if FreeDiskSpace is able to deal with SD card reader as a "disk". Might not...

I'd be interested to see what Powershell sees the drive as...
Well seems like something's up for sure, as the label does not come up in PS...
Capture.PNG
SilverAzide wrote: August 14th, 2021, 4:59 pm One question for the OP, did you actually give the drive a volume label? Sorry for the dumb question, but if you leave the label blank, File Explorer will helpfully show a label of "SD Card", but that label doesn't actually exist.
Hehehe yes, yes I have.
Capture2.PNG
And to answer your later question, it shouldn't be Unicode, it seems to support spaces and lower case letters fine as you can see. It is Fat32 though.
balala wrote: August 15th, 2021, 9:52 am Maybe. Mine is an internal card reader on my laptop, but don't return the label of the card.
I'm starting to think this is the issue. Like I said, this card is Bitlocker protected, but any SD I insert gives me the same run around...
You do not have the required permissions to view the files attached to this post.
User avatar
SilverAzide
Rainmeter Sage
Posts: 1630
Joined: March 23rd, 2015, 5:26 pm

Re: Drive Label not showing (SD Card)

Post by SilverAzide »

pixlplague wrote: August 17th, 2021, 9:47 pm Well seems like something's up for sure, as the label does not come up in PS...
This appears to be as I suspected. You actually did not give this drive disk a label. That is why it is blank. What you see in File Explorer is Windows showing you a default label since you didn't provide one. (This is standard behavior in Windows, it will happen for any disk, not just SD cards.)

Right click the drive in File Explorer and select Properties. Enter a label in the Properties dialog (in the textbox at the top). As soon as you save your changes, Rainmeter will see the label, and so will the PowerShell command.
Last edited by SilverAzide on August 18th, 2021, 1:34 am, edited 1 time in total.
Reason: Nomenclature fix.
Gadgets Wiki GitHub More Gadgets...
User avatar
jsmorley
Developer
Posts: 22374
Joined: April 19th, 2009, 11:02 pm
Location: Fort Hunt, Virginia, USA

Re: Drive Label not showing (SD Card)

Post by jsmorley »

SilverAzide wrote: August 17th, 2021, 10:36 pm This appears to be as I suspected. You actually did not give this drive a label. That is why it is blank. What you see in File Explorer is Windows showing you a default label since you didn't provide one. (This is standard behavior in Windows, it will happen for any disk, not just SD cards.)

Right click the drive in File Explorer and select Properties. Enter a label in the Properties dialog (in the textbox at the top). As soon as you save your changes, Rainmeter will see the label, and so will the PowerShell command.
And don't forget you are naming the "disk", not the "drive".
User avatar
SilverAzide
Rainmeter Sage
Posts: 1630
Joined: March 23rd, 2015, 5:26 pm

Re: Drive Label not showing (SD Card)

Post by SilverAzide »

jsmorley wrote: August 17th, 2021, 11:35 pm And don't forget you are naming the "disk", not the "drive".
Grr, a bad habit. Fixed!
Gadgets Wiki GitHub More Gadgets...
pixlplague
Posts: 4
Joined: August 11th, 2021, 11:59 am

Re: Drive Label not showing (SD Card)

Post by pixlplague »

SilverAzide wrote: August 17th, 2021, 10:36 pm Right click the drive in File Explorer and select Properties. Enter a label in the Properties dialog (in the textbox at the top). As soon as you save your changes, Rainmeter will see the label, and so will the PowerShell command.
I feel like such a moron :?

It worked. Of course. What threw me off is that "Secure SD" is the name I thought gave it... actually I could have sworn I named it that and just never bothered looking up the properties. But wow, talk about a noob moment there. I'm better at this usually, I swear! lol

Thanks so much for the help!
User avatar
balala
Rainmeter Sage
Posts: 13346
Joined: October 11th, 2010, 6:27 pm
Location: Gheorgheni, Romania

Re: Drive Label not showing (SD Card)

Post by balala »

pixlplague wrote: August 31st, 2021, 2:01 pm It worked. Of course. What threw me off is that "Secure SD" is the name I thought gave it... actually I could have sworn I named it that and just never bothered looking up the properties.
It's a good thing you got it working, because as you can see if you read the topic, for some users it doesn't work for SD cards (me and maybe jsmorley), however for others it does work (SilverAzide for instance). So, good if it does for you as well.