It is currently October 25th, 2021, 11:08 pm

Eject USB

Help with creating, editing & fixing problems with skins
User avatar
Sam12345
Posts: 80
Joined: February 27th, 2021, 9:41 pm
Location: London

Re: Eject USB

Post by Sam12345 »

balala wrote: March 24th, 2021, 9:39 pm Remove the UpdateDivider=-1 option from the [MeasureUser] measure, because if this option is there, the measure is never updated.
While removing it i found the source of the issue: IfMatch="Spost". I by mistake deleted it with UpdateDivider=-1 , and when I did undo I saw it was in capital. I changed it to IfMatch="spost", and it is working once again :beer:
balala wrote: March 24th, 2021, 9:39 pm Additionally, where have you added the MouseOverAction and MeasureLeaveAction options?
In [MeterUserName], it wouldn't work in [MeasureUser]
Insert inspirational quote here
User avatar
balala
Rainmeter Sage
Posts: 13345
Joined: October 11th, 2010, 6:27 pm
Location: Gheorgheni, Romania

Re: Eject USB

Post by balala »

Sam12345 wrote: March 24th, 2021, 9:47 pm While removing it i found the source of the issue: IfMatch="Spost". I by mistake deleted it with UpdateDivider=-1 , and when I did undo I saw it was in capital. I changed it to IfMatch="spost", and it is working once again :beer:
Yep, IfMatch is case sensitive. Good if finally you got it working well.
Sam12345 wrote: March 24th, 2021, 9:47 pm In [MeterUserName], it wouldn't work in [MeasureUser]
Same way as neither of IfCondition, nor IfMatch, or IfAction can't work on meters, they belonging to measures and can be used only there, mouse actions (like MouseOverAction and MeasureLeaveAction) can't be used on measures. Using them on measures makes not too much sense, because a measure doesn't have a visual element, it just "measures" something (makes a calculation, parses an online resource, measures a temperature or something similar) but has nothing to show on screen to have something to hover the mouse over.
User avatar
Sam12345
Posts: 80
Joined: February 27th, 2021, 9:41 pm
Location: London

Re: Eject USB

Post by Sam12345 »

balala wrote: March 25th, 2021, 6:09 pm Good if finally you got it working well.
It was until :oops:
Insert inspirational quote here