It is currently September 24th, 2020, 5:05 am

Idle Time Skin Not Working since updating to win10.2004

Help with creating, editing & fixing problems with skins
User avatar
CodeCode
Posts: 20
Joined: September 7th, 2020, 2:24 pm

Idle Time Skin Not Working since updating to win10.2004

Post by CodeCode »

This used to work:

Code: Select all


[MeasureIdle]
Measure=Plugin
Plugin=SysInfo
SysInfoType=IDLE_TIME
IfCondition=MeasureIdle > 59
IfTrueAction=[!SetOption FormatTime Format "%2!i!:%1!02i!"]
IfFalseAction=[!SetOption FormatTime Format "%1!i!"]
MinValue=0
MaxValue=1199

[FormatTime]
Measure=Uptime
SecondsValue=[MeasureIdle]
DynamicVariables=1

[MeterIdleTime]
Meter=String
MeasureName=FormatTime
Fontsize=15
FontFace=#Font#
FontColor=#Color#
AntiAlias=1 
StringAlign=Center
x=99
y=20r
Text=%1
DynamicVariables=1
Has anything changed in Rainmeter in the past few betas?
I am using 4.4.0.3404
Can't fix it if it ain't broke - unless it is in code.
User avatar
jsmorley
Developer
Posts: 21386
Joined: April 19th, 2009, 11:02 pm
Location: Fort Hunt, Virginia, USA

Re: Idle Time Skin Not Working since updating to win10.2004

Post by jsmorley »

Works for me.
User avatar
CodeCode
Posts: 20
Joined: September 7th, 2020, 2:24 pm

Re: Idle Time Skin Not Working since updating to win10.2004

Post by CodeCode »

jsmorley wrote: September 10th, 2020, 1:26 pmWorks for me.
Hmm. I get nothing.

Any known Win10 setting that might forestall this functionality?
Can't fix it if it ain't broke - unless it is in code.
User avatar
jsmorley
Developer
Posts: 21386
Joined: April 19th, 2009, 11:02 pm
Location: Fort Hunt, Virginia, USA

Re: Idle Time Skin Not Working since updating to win10.2004

Post by jsmorley »

CodeCode wrote: September 10th, 2020, 3:42 pm Hmm. I get nothing.

Any known Win10 setting that might forestall this functionality?
Nope. The only thing that comes to mind is if you have some utility of some kind running that is provoking or simulating mouse movements or keyboard strokes.
User avatar
CodeCode
Posts: 20
Joined: September 7th, 2020, 2:24 pm

Re: Idle Time Skin Not Working since updating to win10.2004

Post by CodeCode »

I'll have to look around, some new things sort of 'went on' after the update - like several settings being set to default and others to a custom-type of setting.

Nothing I have should be doing such actions.

I do have a couple of new things installed but none I am aware of that simulate key or mouse actions.
Can't fix it if it ain't broke - unless it is in code.
User avatar
balala
Rainmeter Sage
Posts: 11390
Joined: October 11th, 2010, 6:27 pm
Location: Gheorgheni, Romania

Re: Idle Time Skin Not Working since updating to win10.2004

Post by balala »

Doesn't work the skin at all or zou don!t get the appropriate format on the [FormatTime] meter? Because in second case you probably have to add a DynamicWindowSize=1 option to the [Rainmeter] section. For me the code does work, but it was required me to add this option, to see the change of what is shown.
User avatar
CodeCode
Posts: 20
Joined: September 7th, 2020, 2:24 pm

Re: Idle Time Skin Not Working since updating to win10.2004

Post by CodeCode »

I can see the text meter - all it shows is a zero; "0" and does not update when keypress and mouse actions have stopped.
It used to update immediately, but now does not at all.
Can't fix it if it ain't broke - unless it is in code.
User avatar
balala
Rainmeter Sage
Posts: 11390
Joined: October 11th, 2010, 6:27 pm
Location: Gheorgheni, Romania

Re: Idle Time Skin Not Working since updating to win10.2004

Post by balala »

CodeCode wrote: September 10th, 2020, 8:54 pm I can see the text meter - all it shows is a zero; "0" and does not update when keypress and mouse actions have stopped.
It used to update immediately, but now does not at all.
Make sure you don't hit keys on keyboard and you don't move the mouse, because for me, same as for jsmorley, as he said above, the code does perfectly working. Leave the computer idle.