It is currently February 25th, 2020, 12:52 am

Monstercat Visualizer Displays Special Characters As "?"

Help with creating, editing & fixing problems with skins
Technotastic
Posts: 21
Joined: November 16th, 2019, 3:50 pm

Monstercat Visualizer Displays Special Characters As "?"

Post by Technotastic »

Greetings Rainmeter Community,

This is my first time posting to the forum for help, so please let me know if I have done something incorrectly.

I have been running Monstercat Visualizer for some time now, and overall it works very well. I use it to visualize the music I have hosted in my MediaMonkey media library. The one exception to Monstercat Visualizer's otherwise great functionality is that it seems unable to display Japanese or other special characters in its "Song Info" meter.

=========================================

IMPORTANT EDIT:

I have since discovered that this issue is not, in fact, the fault of Monstercat Visualizer. It is some kind of error that is native to the "NowPlaying" measure. If you create a new meter that does nothing except use the NowPlaying measure to get the current track or artist from MediaMonkey, the exact same issue occurs.

=========================================

Media Monkey seems equiped to display all manner of special characters, as I have had no issues with displaying Japanese/special characters inside the Media Monkey Application. Once it sends the song information to Monstercat Visualizer however, the breakdown appears to occur.

Image

As is usual for the Rainmeter community, I am not the first person to struggle with special characters in their meters. I have referenced the following threads, and attempted to implement their solutions, to no avail.

https://forum.rainmeter.net/viewtopic.php?p=166594
https://forum.rainmeter.net/viewtopic.php?t=4699
https://forum.rainmeter.net/viewtopic.php?t=17108

All of the files in the attached .zip should be encoded in either UTF-16 LE or UCS-2 LE BOM, but this does not seem to have had any effect.

Additional Information:
Rainmeter 4.3.1.3321 (64-bit)
Language: English (1033)
Build time: 2019-09-22 7:26:11
Commit Hash: 0ba4dfc4
Windows 10 Home 1903 64-bit (build 18362) - English (1033)
Path: C:\Program Files\Rainmeter\
SkinPath: C:\Users\Techtastic\Documents\Rainmeter\Skins\
SettingsPath: C:\Techtastic\User\AppData\Roaming\Rainmeter\
IniFile: C:\Users\Techtastic\AppData\Roaming\Rainmeter\Rainmeter.ini

Monstercat Visualizer version 2.1.0

MediaMonkey version 4.1.25.1895

=========================================

I have also made modifications to the Left Song Info Widget in question. I doubt they are the source of my issue, but here are the modifications I have made (I might have missed a modification, but all modifications should be aesthetic only and, to my knowledge, not have any bearing on text processing):

Font Modifications:
-New Media Font

Positioning modifications:
Meter Artist:
-W=400 H=500
-X=100 Y=50

Meter Track:
-W=400 H=500
-X=72 Y=100

Angle modification:
-Both Meter Artist and Meter Track are set to Angle=44.57

=========================================

My frustrations have peaked, and my limited knowledge of rainmeter has lead me to a dead end in terms of solving this issue. I am hoping more knowledgeable people here on the forums can help.

There might not be a solution, or it's possible the issue is a direct result of all the tampering I've done. Any sort of guidance is greatly appreciated. I have attached a .zip of my Monstercat Visualizer skin folder so that anyone inclined to dive into my modification and/or compare it to a fresh download can do so.

Thank you very much for any and all assistance.

-Techtastic

EDIT: In light of discovery mentioned above in the "Important Edit" section, a very large chunk of this initial post is no longer relevant. Monstercat Visualizer isn't the cause of the problem, instead it seems the NowPlaying measure is. However, my problem still persists, this time leaving me even more out of my depth. I have no idea if there's a way to change the way fundamental measures behave. If anyone has any insight into this, it would be greatly appreciated.
You do not have the required permissions to view the files attached to this post.
Last edited by Technotastic on November 16th, 2019, 10:31 pm, edited 1 time in total.
User avatar
balala
Rainmeter Sage
Posts: 9758
Joined: October 11th, 2010, 6:27 pm
Location: Gheorgheni, Romania

Re: Monstercat Visualizer Displays Special Characters As "?"

Post by balala »

Could you please post a song which has Japanese characters? Just to can check what isn1t going on well.
Technotastic
Posts: 21
Joined: November 16th, 2019, 3:50 pm

Re: Monstercat Visualizer Displays Special Characters As "?"

Post by Technotastic »

I have included an image in the original post that shows a piece of the problem. I don't think it embedded correctly, so here's the link:

https://imgur.com/a/MO8ILBN

Additionaly, here are 2 more examples of the issue:

Japanese
Special Characters

Hope this helps.

-Techtastic

P.S. Just realized you might have meant I should supply an audio file. Please let me know if this is the case.
User avatar
balala
Rainmeter Sage
Posts: 9758
Joined: October 11th, 2010, 6:27 pm
Location: Gheorgheni, Romania

Re: Monstercat Visualizer Displays Special Characters As "?"

Post by balala »

Technotastic wrote:
November 16th, 2019, 7:08 pm
P.S. Just realized you might have meant I should supply an audio file. Please let me know if this is the case.
Yes, this is the case. I'd need a such piece to can check not on an image, but directly in Rainmeter. Thanks.
Technotastic
Posts: 21
Joined: November 16th, 2019, 3:50 pm

Re: Monstercat Visualizer Displays Special Characters As "?"

Post by Technotastic »

I apologize for the earlier confusion. I have supplied two files. One contains Japanese characters in the artist field (うさこ - kotu), the other in the song title (At Sunset (feat. オウムのジャングルPARROT JUNGLE 95)). This should allow you to test both the song and artist meters. Please let me know if you require additional files.

(Despite my best efforts I could not get them down to a size that would permit them to be attached, so I hosted a .zip on mediafire. I hope that works, please let me know if it doesn't.)

https://www.mediafire.com/file/jyp2mc3ou3qcd94/Song_Files.zip/file

Thank you very much!

-Techtastic
User avatar
balala
Rainmeter Sage
Posts: 9758
Joined: October 11th, 2010, 6:27 pm
Location: Gheorgheni, Romania

Re: Monstercat Visualizer Displays Special Characters As "?"

Post by balala »

Technotastic wrote:
November 16th, 2019, 7:32 pm
(Despite my best efforts I could not get them down to a size that would permit them to be attached, so I hosted a .zip on mediafire. I hope that works, please let me know if it doesn't.)
No, it's alright, I just downloaded the package.
Let me check. Will be back soon.
Technotastic
Posts: 21
Joined: November 16th, 2019, 3:50 pm

Re: Monstercat Visualizer Displays Special Characters As "?"

Post by Technotastic »

Thank you so much! Your help is immensely appreciated!!
User avatar
balala
Rainmeter Sage
Posts: 9758
Joined: October 11th, 2010, 6:27 pm
Location: Gheorgheni, Romania

Re: Monstercat Visualizer Displays Special Characters As "?"

Post by balala »

Technotastic wrote:
November 16th, 2019, 7:58 pm
Thank you so much! Your help is immensely appreciated!!
Unfortunately there is a small problem:
Song2.png
Song1.png
I have no MediaMonkey, so I had to try with Windows Media Player. But with WMP, I got the Japanese characters alright.
You do not have the required permissions to view the files attached to this post.
Technotastic
Posts: 21
Joined: November 16th, 2019, 3:50 pm

Re: Monstercat Visualizer Displays Special Characters As "?"

Post by Technotastic »

Fascinating! My machine produces the exact same results. Perhaps this means MediaMonkey is sending its special characters to the meter in a way it can't recognize? I am unsure, as I do not know how the meter is getting the information from MediaMonkey.

Is there any recommended course of action from here? I don't know what to do next. As always, any guidance is appreciated.
User avatar
balala
Rainmeter Sage
Posts: 9758
Joined: October 11th, 2010, 6:27 pm
Location: Gheorgheni, Romania

Re: Monstercat Visualizer Displays Special Characters As "?"

Post by balala »

Technotastic wrote:
November 16th, 2019, 8:48 pm
Fascinating! My machine produces the exact same results. Perhaps this means MediaMonkey is sending its special characters to the meter in a way it can't recognize? I am unsure, as I do not know how the meter is getting the information from MediaMonkey.
Let's see if I understood well. So, with MediaMonkey you don't get the Japanese characters, but those question marks. But with WMP the Japanese characters are shown correctly. Is this right?