It is currently October 15th, 2019, 5:06 am

Button not working, Cut in half + hover issue

Help with creating, editing & fixing problems with skins
User avatar
Vx_Lotus
Posts: 34
Joined: July 30th, 2019, 7:37 am

Button not working, Cut in half + hover issue

Vx_Lotus » August 6th, 2019, 12:36 am

Hey, I was reviewing your code in the small terminal (Umbrella\terminals\small) @Eclectic-Tech

[Close]
Meter=button
ButtonImage=#@#Images\#GraphicTheme#\closebutton-sepia-#TerminalTheme#
ImageTint=#BlueColor#
x=([Image:W]-18)
y=4
ButtonCommand=!DeActivateConfig

You indicated 3 types of 20x20 images with different colors in the associated file.
I was trying to mimic the button that you made, it is hidden then when you move your mouse over it, it pops up and you can click it....I didn't do that exactly ~ Mine isn't that complicated, I was just trying to put the image in the spot and then be able to hover and click. Something happened in my code and now my button image is cut in half and to top it off. When you move the mouse over it, the image flips horizontal. You might be interested in this added \ change of scenery. Its a small file.

Code: Select all

[Close]
Meter=button
x=105
y=13
ButtonImage=#@#Images\GreenUmbrellaButton20.png
ButtonCommand=!DeActivateConfig
MouseOverAction=[!SetOption MeterText Text "Mouse OVER state"][!UpdateMeter MeterText][!Redraw]
MouseLeaveAction=[!SetOption MeterText Text "Mouse OFF state"][!UpdateMeter MeterText][!Redraw]
LeftMouseDownAction=[!SetOption MeterText Text "Mouse DOWN state"][!UpdateMeter MeterText][!Redraw]
Knowing that my file locations may not work for you in this case, I simple uploaded the 3 you need + referenced the file placement that I currently have. The GREEN Icon was to go to the square (TOP RIGHT)… Can anyone help?
You do not have the required permissions to view the files attached to this post.
User avatar
eclectic-tech
Rainmeter Sage
Posts: 3568
Joined: April 12th, 2012, 9:40 pm
Location: Cedar Point, Ohio, USA

Re: Button not working, Cut in half + hover issue

eclectic-tech » August 6th, 2019, 1:28 am

A Button Meter is a special image meter and requires the use of a 3-part image.

You can read about creating them in this manual tip.

The issue you are seeing is the result of using a single-part image as the source for your button meter.

Here is a 3-part image of your button I created:
GreenUmbrellaButton21x63.png
Download it and save it in "@Resources\Images". Edit your skin to use this image and load your ID skin.

Everything should line up and will react to mouse actions as described in the button meter.
You do not have the required permissions to view the files attached to this post.
User avatar
Vx_Lotus
Posts: 34
Joined: July 30th, 2019, 7:37 am

Re: Button not working, Cut in half + hover issue

Vx_Lotus » August 6th, 2019, 3:36 am

Thanks I will test it.
Fixed
What software do you personally use to do this?

I wasn't able to figure it out in gimp and windows paint isn't up to "par." ~I can't make 3 part images with my software.
User avatar
jsmorley
Developer
Posts: 19544
Joined: April 19th, 2009, 11:02 pm
Location: Fort Hunt, Virginia, USA

Re: Button not working, Cut in half + hover issue

jsmorley » August 6th, 2019, 5:00 am

Vx_Lotus wrote:
August 6th, 2019, 3:36 am
Thanks I will test it.
Fixed
What software do you personally use to do this?

I wasn't able to figure it out in gimp and windows paint isn't up to "par." ~I can't make 3 part images with my software.
You might take a look at alternative 2 here: https://docs.rainmeter.net/tips/button-images/
User avatar
Vx_Lotus
Posts: 34
Joined: July 30th, 2019, 7:37 am

Re: Button not working, Cut in half + hover issue

Vx_Lotus » August 6th, 2019, 5:53 am

The link to image magick is broken http://www.imagemagick.org/script/script/download.php Gimp seems to be the only route. I spend some more time and learn how to use it more efficiently.
windows 10 core's i3 and up to core i9 here, From home office to home professional. 64bits the way to go.

A- picture of my project. ^^
You do not have the required permissions to view the files attached to this post.
User avatar
jsmorley
Developer
Posts: 19544
Joined: April 19th, 2009, 11:02 pm
Location: Fort Hunt, Virginia, USA

Re: Button not working, Cut in half + hover issue

jsmorley » August 6th, 2019, 10:16 am

Here is the new link for ImageMagick

https://imagemagick.org/script/download.php#windows