It is currently December 14th, 2018, 6:46 am

steam mini launcher: "too many requests"

Help with creating, editing & fixing problems with skins
Posts: 1
Joined: November 28th, 2017, 12:42 pm

steam mini launcher: "too many requests"

9bananas » November 28th, 2017, 1:10 pm

so i've been using the steam mini launcher for quite a while, but it's been acting up recently. i've done all the usual troubleshooting stuff, checked the ini, and so on.

the problem:

i think the problem is with steam: every time i try to view my recent games tab through my browser (WITHOUT logging in to steam) i get an error: too many requests, try again later....even if it's the first request i've sent today?! (also note that this happens with ANY subpage of my profile)

here's the weird thing: i can look at my recent games just fine on my phone! so it's apparently ip-address related.

to summarize:
-the launcher/skin is just blank where the games should be
-my ini is set correctly
-steam profile is set to public (double checked!)

so yeah, appaerently it's a problem with the mini launcher sending too many requests.
now i don't wanna login through my browser every time i turn my pc on, just so the launcher can get an update on my recently played games.

i tried an alternative launcher, ran into another problem:
the author only specified a single library is spread across 3 drives for hard drive space/performance that's the reason i'd really like to use the mini launcher, it's simpler to use (in theory at least-.-)

i've searched around for a bit looking for clues about the "too many requests" thingy, didn't find anything about that, at least not anything that has to do with my specific problem...

anybody have some advice for me? i really like the minimalistic design of this skin, so i'd like to use it if possible.
but i won't hang on to it, if the issues aren't easily resolveable...

alternative skins are super welcome!

thanks in advance folks!

EDIT: alternative i tried was the steam wheel, that was the one with just one path. i figured in the meantime i could probably just use shortcuts to launch from a central i (probably) have an alternative. gonna leave this topic up anyways, maybe it helps someone figure out their issue.