VU Level Metres in Rainmeter?

Help with creating, editing & fixing problems with skins
User avatar

Re: VU Level Metres in Rainmeter?

November 21st, 2017, 8:47 pm
sl23
   [281 posts]

balala wrote:removing the [mProcessFoobar] and [mProcessMuLab] measures fixed the issue,

These don't cause me any issue. MuLab is a DAW and the two processes activate the skins VU section.
Commenting out these sections does NOT stop the error?! :thumbdown:

balala wrote:this section had been set to place the meters which use it, to X=(26+200*[mPeakLeft]), which means that both peak meters are placed on the same position

I know I found that out ;-) I thought I solved it by adding a Y=7R, but as I wrote this I think I misunderstood! You mean they have the same db value, yes? I didn't twig that one! So Thanks for pointing it out :thumbup:

balala wrote:Add the following two options to both the [mPeakLeft] and [mPeakRight] measures:

Code: Select all

IfCondition=(#CURRENTSECTION#>=#ResetLevel#)
IfTrueAction=[!DisableMeasure "#CURRENTSECTION#"][!UpdateMeasure "#CURRENTSECTION#"][!EnableMeasure "#CURRENTSECTION#"]

This seems to limit the peak value, which means it stops it going right to the end of the metre dependant on the value set in the variable. Set it to 0.5 and it only goes half way, set it to 0.3 it goes only 30% towards the right.

balala wrote:with this solution if any of the maxs doesn't change for three seconds, the appropriate peak is reset.
Also add the following two measures:

This didn't work!

At first I thought all the code was required, but Then I read the part at the end that said "Now you have to decide which solution do you prefer." So I commented out the first 'IfCondition' lines and just used the second part, which is just as you preferred! ;-)

But neither method works for me! :-(
User avatar

Re: VU Level Metres in Rainmeter?

November 21st, 2017, 8:54 pm
sl23
   [281 posts]

eclectic-tech wrote:I noticed the same issues balala pointed out about style.

I also received a playertype error; add PlayerType=STATUS to the mPlayer section.

The image error message refers to both a '0.png' and '1.png' image on my system.

Rube here:
You could create transparent 1x1 pixel images and save them as '0.png' and '1.png'; (Rube Goldberg hard at work! :D ) this will eliminate the errors and you not have to remove the measures testing for processes.
However, I use winamp which meant these measure always hide the bars because neither process is active. If you are going to distribute, you would need to compare the player process used by end users.

One note on balala's last suggestion (which I like!)... because the skin has an Update of 25 ms, in order to "hold" the value for 3 seconds, the 'ResetTime' variable would have to be 40 times the number of seconds, so instead of 3 set it to 120 to hold the value for 3 seconds (25*120=3000ms).

Enough from me! ;-)

Thank you both for your help :thumbup:

As stated above commenting out the process sections does NOT solve the issue, meaning it can't be that causing the errors?
How does specifying to measure processes cause an image error? I don't understand that. Is there something missing here?

What's the PlayerType=STATUS for? I don't get the error.

The only error I get is the 0.png one.
User avatar

Re: VU Level Metres in Rainmeter?

November 21st, 2017, 8:56 pm
balala
Rainmeter Sage   [4985 posts]

eclectic-tech wrote:One note on balala's last suggestion (which I like!)... because the skin has an Update of 25 ms, in order to "hold" the value for 3 seconds, the 'ResetTime' variable would have to be 40 times the number of seconds, so instead of 3 set it to 120 to hold the value for 3 seconds (25*120=3000ms).

Both measures [MeasureTimeLeft] and [MeasureTimeRight] have set an UpdateDivider=40 option, exactly to can set the ResetTime variable in seconds. ResetTime=120 would take too long to reset the peaks.
User avatar

Re: VU Level Metres in Rainmeter?

November 21st, 2017, 9:12 pm
sl23
   [281 posts]

I've just systematically gone through the skin, commenting entire sections out in order to disable them completely.
I got as far as the Peaks sections (all at once) and then the errors stopped.

Re-enabling everything except the Peak sections returned no errors. The errors are somewhere in the Peaks, not the process monitors. This includes my previous versions, is it to do with this line:
;Meter=Image

Is it a requirement to specify a PNG file? I have decided to go without that necessity and simply allow Rm to draw it's own, is that an incorrect solution?

:thumbup:
User avatar

Re: VU Level Metres in Rainmeter?

November 21st, 2017, 9:26 pm
sl23
   [281 posts]

I did just notice though that the two process monitors are conflicting, not sure how this affects Rm but haven't had issues in practise. Commented out the MULAB monitor just for now.
User avatar

Re: VU Level Metres in Rainmeter?

November 21st, 2017, 9:28 pm
eclectic-tech
Rainmeter Sage   [2323 posts]

balala wrote:Both measures [MeasureTimeLeft] and [MeasureTimeRight] have set an UpdateDivider=40 option, exactly to can set the ResetTime variable in seconds. ResetTime=120 would take too long to reset the peaks.
@ balala ... Speed reading got me again :D

@sl23 ... Without a PLAYERTYPE=???? in the measure my system generated a "Invalid PlayerType=' message in the log.
Running RM V 4.2.0 beta r3001 64-bit
User avatar

Re: VU Level Metres in Rainmeter?

November 21st, 2017, 9:33 pm
balala
Rainmeter Sage   [4985 posts]

sl23 wrote:How does specifying to measure processes cause an image error? I don't understand that. Is there something missing here?

The issue is caused by the MeasureName=mPeakLeft and MeasureName=mPeakRight options of the [PeakLeft] and [PeakRight] meters. These meters are using SolidColor (SolidColor=235,70,0,255) and they don't need a MeasureName option. On the other hand if both are used, the MeasureName option overrides the Solidcolor / ImageName option (see the Note here). So, if a MeasureName option is given, the Image meter will want to show an image which should have the name returned by the named measure. If not specified, the meter uses the default extension, which is .png. [mPeakLeft] and [mPeakRight] usually return values below 0.5, which means 0 from the point of view of the Image meter, that's why we get the error.
I omitted this detail. Sorry...
User avatar

Re: VU Level Metres in Rainmeter?

November 21st, 2017, 9:39 pm
sl23
   [281 posts]

Yay! I removed MeasureName=mPeak*** from each metre and error's all gone now :D
Nice work balala, thanks for solving that.
User avatar

Re: VU Level Metres in Rainmeter?

November 21st, 2017, 9:42 pm
balala
Rainmeter Sage   [4985 posts]

Glad to help.
User avatar

Re: VU Level Metres in Rainmeter?

November 21st, 2017, 9:52 pm
sl23
   [281 posts]

Well, there seems to be no progress made towards the Peaks solution I was hoping for, but at least there are now some errors solved that I didn't even know about! :sly: :D

Thank you for solving those unknown issues, maybe I should be satisfied with it how it is.

I did notice though that the reduction in the Clip Attack time has made it more coherent. There was just something not right about how the peaks were hitting the top but no clip came on. I've only just thought about changing that! :handtohead:

Thank you again for your expertise, massive help as always :thumbup:

Return to “Help: Rainmeter Skins”



Who is online

Users browsing this forum: No registered users and 4 guests