It is currently April 13th, 2021, 11:03 am

Thread for help with the Shape meter

Help with creating, editing & fixing problems with skins
Tony Ryan
Posts: 17
Joined: December 7th, 2016, 2:27 pm

Re: Thread for help with the new Shape meter

Post by Tony Ryan »

Thanks a lot Sephirotess that worked...but the bar only comes out so far
compared to an ordinary bar meter,maybe i do need to find a percentage.
thanks again....
User avatar
sephirotess
Posts: 333
Joined: December 8th, 2016, 6:45 am

Re: Thread for help with the new Shape meter

Post by sephirotess »

Tony Ryan wrote:Thanks a lot Sephirotess that worked...but the bar only comes out so far
compared to an ordinary bar meter,maybe i do need to find a percentage.
thanks again....
You're welcome :welcome:.

The code is based on the percentage of use of the "download". It may not be very effective for real-time downloading.
It might be more efficient if it worked on an average download. Something like that.

Code: Select all

[MeasureNetOut]
Measure=NetOut
NetOutSpeed=#maxUpload#
AverageSize=5
It's just an assumption. Someone will probably be able to help you more than I do on this subject.
User avatar
CyberTheWorm
Posts: 766
Joined: August 22nd, 2016, 11:32 pm
Location: Surrey, B.C., Canada

Re: Thread for help with the new Shape meter

Post by CyberTheWorm »

Try this link https://docs.rainmeter.net/tips/network-skin/ it has a good tutorial in getting your settings correct
The only source of knowledge is experience. Albert Einstein
Deviant Art Page
User avatar
balala
Rainmeter Sage
Posts: 12546
Joined: October 11th, 2010, 6:27 pm
Location: Gheorgheni, Romania

Re: Thread for help with the new Shape meter

Post by balala »

Be careful, the NetInSpeed and NetOutSpeed options are deprecated, you should avoid using them.
Tony Ryan
Posts: 17
Joined: December 7th, 2016, 2:27 pm

Re: Thread for help with the new Shape meter

Post by Tony Ryan »

ok thanks Sephirotess tried the averageSize=5 but still the same.
and thanks cybertheworm/balala for the tips.I downloaded jsmorleys
so just gonna use that,but i still think Sephrotess's shape bar meter is cool.
thanks Tony...
User avatar
ikarus1969
Posts: 426
Joined: February 28th, 2011, 3:20 pm
Location: Vienna, Austria

help for gradients on combined shapes needed

Post by ikarus1969 »

Hi!

today i need some help with defining gradients on combined shapes.

my test-skin looks like this.
Screenshot Rainmeter Combined Gradients.jpg
in the first line you see a combined shape with a LinearGradient - it works as i thought it should.

in the line below you see the same shape(s) defined with RadialGradient(s) and i would expect to have a radial gradient starting from the center of the combined skin with a dark red over a yellow at half way and ending with a dark blue at the borders of the shape.

The first shape in 2nd line has the same stops as the shape with the LinearGradient but i only see th last defined color.
So i played around with the stops on the othe shapes in the 2nd line but i can't figure out how to set to achieve what i want.

Obviously it doesn't work with the definitions made.

Could someone explain to me how i manage to get the radial gradient to work?

code for the test-skin:

Code: Select all

[Rainmeter]
Update=1000
DynamicWindowSize=1
BackgroundMode=2
SolidColor=FFFFFFFF

[Meter_Shape_CombinedGradients]
Meter=SHAPE

; LINEAR Gradient
Shape= Ellipse (#WORKAREAX# + 100 - 30), (#WORKAREAY# + 75), 50, 50 | Fill LinearGradient LinGrad
Shape2=Ellipse (#WORKAREAX# + 100 + 30), (#WORKAREAY# + 75), 50, 50
Shape3=Combine Shape | Union Shape2
LinGrad=0 | 800000FF ; 0.0 | FFFF00FF ; 0.5 | 004080FF ; 1.0

; RADIAL Gradient(s)
Shape4=Ellipse (#WORKAREAX# + 100 - 30), (#WORKAREAY# + 200), 50, 50 | Fill RadialGradient RadGrad1
Shape5=Ellipse (#WORKAREAX# + 100 + 30), (#WORKAREAY# + 200), 50, 50
Shape6=Combine Shape4 | Union Shape5
RadGrad1=0, 0 | 800000FF ; 0.0 | FFFF00FF ; 0.5 | 004080FF ; 1.0

Shape7=Ellipse (#WORKAREAX# + 300 - 30), (#WORKAREAY# + 200), 50, 50 | Fill RadialGradient RadGrad2
Shape8=Ellipse (#WORKAREAX# + 300 + 30), (#WORKAREAY# + 200), 50, 50
Shape9=Combine Shape7 | Union Shape8
RadGrad2=0, 0 | 800000FF ; 0.0 | FFFF00FF ; 10.0 | 004080FF ; 20.0

Shape10=Ellipse (#WORKAREAX# + 500 - 30), (#WORKAREAY# + 200), 50, 50 | Fill RadialGradient RadGrad3
Shape11=Ellipse (#WORKAREAX# + 500 + 30), (#WORKAREAY# + 200), 50, 50
Shape12=Combine Shape10 | Union Shape11
RadGrad3=0, 0 | 800000FF ; 0.0 | FFFF00FF ; 1.0 | 004080FF ; 1.5

AntiAlias=1
DynamicVariables=1
You do not have the required permissions to view the files attached to this post.
User avatar
ikarus1969
Posts: 426
Joined: February 28th, 2011, 3:20 pm
Location: Vienna, Austria

Re: Thread for help with the new Shape meter

Post by ikarus1969 »

Maybe a problem with a bounding-box of the combined shape when using a radial shape? Hmmm....
User avatar
jsmorley
Developer
Posts: 21617
Joined: April 19th, 2009, 11:02 pm
Location: Fort Hunt, Virginia, USA

Re: Thread for help with the new Shape meter

Post by jsmorley »

Not quite sure, perhaps theAzack9 and / or Brian can take a look a this.

Here is some code, simply based on the example in the documentation that seems to demonstrate the issue.

Code: Select all

[Rainmeter]
Update=1000
DynamicWindowSize=1
BackgroundMode=2
SolidColor=255,0,0,90

[MeterShape]
Meter=Shape
Shape=Ellipse 50,50,50 |  | StrokeWidth 0 | Fill RadialGradient MyGradient1
MyGradient1=0,0 | 155,200,232,255 ; 0.0 | 6,46,75,255 ; 1.0
Shape2=Ellipse 170,50,50 | StrokeWidth 0 | Fill RadialGradient MyGradient2
MyGradient2=0,0,20,20 | 155,200,232,255 ; 0.0 | 6,46,75,255 ; 1.0
Shape3=Combine Shape | Union Shape2
If you comment out Shape3, then the two individual shapes get the proper gradient just fine, when combined, it seems like something goes sideways.
User avatar
Brian
Developer
Posts: 2114
Joined: November 24th, 2011, 1:42 am
Location: Utah

Re: Thread for help with the new Shape meter

Post by Brian »

@ikarus1969: Thanks for reporting this bug. It has been fixed for the next beta.

-Brian
User avatar
ikarus1969
Posts: 426
Joined: February 28th, 2011, 3:20 pm
Location: Vienna, Austria

Re: Thread for help with the new Shape meter

Post by ikarus1969 »

Brian wrote:...Thanks for reporting...
Thanks for investigating and fixing!

EDIT:
looks good now (2793):
Screenshot.jpg
You do not have the required permissions to view the files attached to this post.