It is currently September 24th, 2020, 7:36 am

Opening Skins

General topics related to Rainmeter.
roan420
Posts: 11
Joined: February 13th, 2018, 2:11 pm

Opening Skins

Post by roan420 »

I'm using the CogsTubesGauges skin. The skin launcher has two open buttons. I'm trying to get the open buttons to launch the ToDo and Google_search from the CTGauges_extension_pack. I have copied the CTGauges_extension_pack into the CogsTubesGauges folder. I have tried the following codes but it will not open. The Icons I have assigned to the launcher show up. What am I doing wrong?

; --- 7
ItemText-7=To Do
ItemAction-7=[!ToggleConfig "#Layout#\ToDo" "ToDo.ini"]
ItemIcon-7=#@#Icons\10.png


; --- 7
ItemText-7=To Do
ItemAction-7=[!ToggleConfig "#Layout#\CTGauges_extension_pack\ToDo" "ToDo.ini"]
ItemIcon-7=#@#Icons\10.png
User avatar
balala
Rainmeter Sage
Posts: 11392
Joined: October 11th, 2010, 6:27 pm
Location: Gheorgheni, Romania

Re: Opening Skins

Post by balala »

roan420 wrote:I have copied the CTGauges_extension_pack into the CogsTubesGauges folder. I have tried the following codes but it will not open. The Icons I have assigned to the launcher show up. What am I doing wrong?
Very hard to say this way, but have you made a Refresh all? When you're moving skins, a such operation is absolutely needed, because without it, Rainmeter doesn't see the newly moved / created skins.
roan420
Posts: 11
Joined: February 13th, 2018, 2:11 pm

Re: Opening Skins

Post by roan420 »

Yes I've done the refresh all. I had it working about 9 months ago. Then computer crashed and had to reinstall Windows. I can't remember the code or what I did to make it open the CTGauges_extension_pack from the CogsTubesGauges launcher.
User avatar
balala
Rainmeter Sage
Posts: 11392
Joined: October 11th, 2010, 6:27 pm
Location: Gheorgheni, Romania

Re: Opening Skins

Post by balala »

Check the log. What it show?
roan420
Posts: 11
Joined: February 13th, 2018, 2:11 pm

Re: Opening Skins

Post by roan420 »

Unable to read file: C:\Users\antho\Documents\Rainmeter\Skins\CTGauges_extension_pack\@Resources\Configs\CommonStyles.inc (CTGauges_extension_pack\ToDo\ToDo.ini)
roan420
Posts: 11
Joined: February 13th, 2018, 2:11 pm

Re: Opening Skins

Post by roan420 »

StringStyle=NONE is not valid (CogsTubesGauges\CTGauges_extension_pack\ToDo\ToDo.ini - [MeterText])
!ActivateConfig: Invalid parameters
Last edited by roan420 on June 3rd, 2018, 8:22 pm, edited 1 time in total.
User avatar
balala
Rainmeter Sage
Posts: 11392
Joined: October 11th, 2010, 6:27 pm
Location: Gheorgheni, Romania

Re: Opening Skins

Post by balala »

roan420 wrote:Unable to read file: C:\Users\antho\Documents\Rainmeter\Skins\CTGauges_extension_pack\@Resources\Configs\CommonStyles.inc (CTGauges_extension_pack\ToDo\ToDo.ini)
This means that the @Resources\Configs\CommonStyles.inc file is missing. This can be the cause. But because I don't know the skin you're talking about, I can't say more. Check to see if you can find the missing file.
roan420 wrote:StringStyle=NONE is not valid (CogsTubesGauges\CTGauges_extension_pack\ToDo\ToDo.ini - [MeterText])
What is this? Do you see this in the log, as well?
roan420
Posts: 11
Joined: February 13th, 2018, 2:11 pm

Re: Opening Skins

Post by roan420 »

Yes all of this is in the log. I'll look at the files and see what is missing. Thanks for your help. I'll let you know what I find out.
User avatar
balala
Rainmeter Sage
Posts: 11392
Joined: October 11th, 2010, 6:27 pm
Location: Gheorgheni, Romania

Re: Opening Skins

Post by balala »

roan420 wrote:Yes all of this is in the log. I'll look at the files and see what is missing. Thanks for your help. I'll let you know what I find out.
If you don't succeed, pack the whole config and upload it, to can check.
roan420
Posts: 11
Joined: February 13th, 2018, 2:11 pm

Re: Opening Skins

Post by roan420 »

Thanks for your help balala.
I got it figured out. I had a bunch of files and images that needed to be copied to folders.
You got me set on the right path...Thanks again !!