It is currently June 25th, 2019, 6:25 am

Speedfan and Windows 8

Post reviews, recommendations and questions about other software.
User avatar
jsmorley
Developer
Posts: 19268
Joined: April 19th, 2009, 11:02 pm
Location: Fort Hunt, Virginia, USA

Speedfan and Windows 8

jsmorley » November 10th, 2012, 4:52 pm

I found that once I changed over to Windows 8, Speedfan had trouble automatically starting when it was just added to the Startup folder in the Windows Start menu, or by adding it to the "run" registry entry. I suspect this has to do with the fact that Speedfan needs administrator access to your hardware sensors, and Windows 8 is a bit more strict about security.

I have UAC turned off, so it is not related to that...

I was able to get it working right, but it took running Speedfan as a Scheduled Task at startup.

1) In the Modern UI Start screen, type "schedule" to get to the Scheduled Tasks application:
01.png
2) Create a new task:
02.png
3) Give the task a name, and set the options like this:
03.png
4) Set the trigger like this:
04.png
5) Set the action like this (your path may vary):
05.png
Click Ok to save the task, and restart Windows to make sure it works.
You do not have the required permissions to view the files attached to this post.
User avatar
Seahorse
Posts: 1220
Joined: June 9th, 2010, 5:56 pm
Location: Locks heath, UK

Re: Speedfan and Windows 8

Seahorse » November 10th, 2012, 6:01 pm

Speedfan has failed to run from the Startup in Vista & Win 7 for a long time, was broken by Speedfan around 4.41 or so as I recall.
"Regrettably your planet is one of those scheduled for demolition"
Mike

My Skins at DeviantArt

User avatar
jsmorley
Developer
Posts: 19268
Joined: April 19th, 2009, 11:02 pm
Location: Fort Hunt, Virginia, USA

Re: Speedfan and Windows 8

jsmorley » November 10th, 2012, 6:01 pm

Seahorse wrote:Speedfan has failed to run from the Startup in Vista & Win 7 for a long time, was broken by Speedfan around 4.41 or so as I recall.
Worked just fine for me in Win7, but ok.
User avatar
UnforgivenRevival
Posts: 317
Joined: June 7th, 2012, 2:25 am
Location: Philadelphia, PA

Re: Speedfan and Windows 8

UnforgivenRevival » November 11th, 2012, 1:01 am

I personally think the reason why speedfan doesnt like to start up when a user logs on is because it requires opening a UAC prompt when started, But I could be wrong. I never turned UAC off in my case, So I thought that was the problem for me. If it still has a problem even with UAC turned off, Im not totally sure, But once added through task scheduler there isnt any problems. At least thats what happened for me in both 7 and 8. It might be different for different machines/hardware. :confused: Simple solution is just to do it this way and never worry about it again. Good tutorial though. :thumbup: