It is currently June 26th, 2019, 4:47 pm

favicon for forum

Discussion about the documentation, main Rainmeter site and forums.
User avatar
gschoppe
Developer
Posts: 93
Joined: April 26th, 2009, 8:30 pm
Location: St Johnsbury, VT

favicon for forum

gschoppe » April 27th, 2009, 11:47 am

the forum needs a favicon to make it easier to find in bookmarks and sets of tabs... extracting the icon from rainmeter.exe yields a pretty recognizable icon at 16x16 and 32x32

the favicon is referenced with the line:

<link rel="icon" type="image/vnd.microsoft.icon" href="/somepath/image.ico" />

in the head of each page
Image
dragonmage
Developer
Posts: 1296
Joined: April 3rd, 2009, 4:31 am
Location: NC, US

Re: favicon for forum

dragonmage » April 27th, 2009, 1:59 pm

Yes it does. We had one before the host change. Maybe Rorix will come along and fix that.
sgtevmckay

Re: favicon for forum

sgtevmckay » April 27th, 2009, 3:50 pm

you know, you are absolutely right, I never thought about it till now, we did have the favicon until we moved hosts.

Hoefully a code fix, and Rorix should be around for a little bit today.
User avatar
GhostMatrix
Rainmeter Sage
Posts: 142
Joined: April 18th, 2009, 8:26 pm
Location: Montreal, Quebec, Canada 45.5658°N, 73.5898°W UTC -5

Re: favicon for forum

GhostMatrix » April 27th, 2009, 8:41 pm

When I log the first time I select the forum skin subsilver2, when I log on the site the favicon appear in the browser !
Even if I'm not logged if I click on the User Control Panel at the top of the page and the favicon will appear on this page.

A temporary Solution:
Delete your old bookmark and go to the site, click on the User Control Panel at the top of the page and the favicon will appear, click on the Rainmeter banner to go on the forum and bookmark the site again and you will have the favicon in your bookmarks list.

GM

Image
If at first you don't succeed; call it version 0.1

Image
dragonmage
Developer
Posts: 1296
Joined: April 3rd, 2009, 4:31 am
Location: NC, US

Re: favicon for forum

dragonmage » April 28th, 2009, 4:44 pm

It appears that only subsilver2 has the favicon.
sgtevmckay

Re: favicon for forum

sgtevmckay » April 28th, 2009, 4:59 pm

Oops.

Ned small code update
User avatar
gschoppe
Developer
Posts: 93
Joined: April 26th, 2009, 8:30 pm
Location: St Johnsbury, VT

Re: favicon for forum

gschoppe » April 29th, 2009, 2:05 am

for some reason, the link rel is missing from the header template... replace that with the one from subsilver, and we're golden
Image
Rorix
Developer
Posts: 21
Joined: April 3rd, 2009, 3:47 am
Location: New Zealand

Re: favicon for forum

Rorix » April 29th, 2009, 6:29 am

I've added the code. I'm not sure why it disappeared
dragonmage
Developer
Posts: 1296
Joined: April 3rd, 2009, 4:31 am
Location: NC, US

Re: favicon for forum

dragonmage » April 29th, 2009, 10:59 am

Thanks Rorix!
sgtevmckay

Re: favicon for forum

sgtevmckay » April 29th, 2009, 8:25 pm

Thank you sir