It is currently June 16th, 2021, 10:56 am

Skin overlays all windows when clicking on desktop

Report bugs with the Rainmeter application and suggest features.
dethknite
Posts: 5
Joined: May 7th, 2021, 3:19 pm

Re: Skin overlays all windows when clicking on desktop

Post by dethknite »

I have had this issue and have tried several things (DDU, multiple nvidia driver versions, disabling wallpaper engine, enabling/disabling hardware-accelerated gpu scheduling in Win10, disabling/enabling hardware acceleration in Rainmeter, nvidia profiles, deleting icon/thumb cache, and lastly just disabled the Launch folder in separate process setting). Sometimes things seem to make it a bit better, but it has always persisted. The things that seemed to help the most:

* Set widgets to "bottom".
* Clear icon cache (helps reduce occurances to less often for awhile).
* disabling Launch folder in separate process (helps reduce occurances to less often for awhile).

* Note: I do have multiple gpus on the pc... but have verified settings in Rainmeter to ensure they are all on the same (primary) gpu.
You do not have the required permissions to view the files attached to this post.
dethknite
Posts: 5
Joined: May 7th, 2021, 3:19 pm

Re: Skin overlays all windows when clicking on desktop

Post by dethknite »

A few other options to try...
* Set all Rainmeter widgets to "Bottom" position.
* Clear the check box "Keep on Screen" (this was something I have not tried until now).
dethknite
Posts: 5
Joined: May 7th, 2021, 3:19 pm

Re: Skin overlays all windows when clicking on desktop

Post by dethknite »

* A follow-up: I moved my Windows pagefile from a 5400 RPM drive to my SSD, and have noticed that the issue is almost non-existent (occurs maybe once every 30 clicks on the desktop when a window was in foreground as opposed to about every other click).