It is currently October 22nd, 2021, 7:01 am

[!Delay x] bug/glitch

Report bugs with the Rainmeter application and suggest features.
User avatar
ShadowDragon
Posts: 44
Joined: January 28th, 2021, 4:30 pm

[!Delay x] bug/glitch

Post by ShadowDragon »

this bug or glitch is something weird that might be able to fix.

in my skin (under construction) I use a [!Delay x] option, this option has a weird bug or glitch


Example 1 = [!Delay "150"][!ShowMeter "Group1"] [!HideMeter "Group2"] <-- works

Example 2= [!Delay "150"] [!ShowMeter "Group1"] [!HideMeter "Group2"] <-- DOES NOT works.

Now a member here named "balala" found out that [!Delay "150"] DOES NOT work, if there is a space behind it,
but it does work when the space is gone, which in my opinion should work both ways (with or without a space).

The question to this, is this is a bug or glitch and is it able to fix it or is this made intentional?
User avatar
jsmorley
Developer
Posts: 22372
Joined: April 19th, 2009, 11:02 pm
Location: Fort Hunt, Virginia, USA

Re: [!Delay x] bug/glitch

Post by jsmorley »

I think that is a minor bug. We will look into it.

I actually don't recommend extra white space in Rainmeter code, but we do try to account for it and ignore it, and it certainly would be good to be consistent with that.

Thanks for reporting.
User avatar
balala
Rainmeter Sage
Posts: 13337
Joined: October 11th, 2010, 6:27 pm
Location: Gheorgheni, Romania

Re: [!Delay x] bug/glitch

Post by balala »

jsmorley wrote: February 6th, 2021, 3:25 pm I think that is a minor bug. We will look into it.

I actually don't recommend extra white space in Rainmeter code, but we do try to account for it and ignore it, and it certainly would be good to be consistent with that.
Those spaces are ignored after all bangs, excepting !Delay. As ShadowDragon said, the LeftMouseUpAction=[!Delay "150"][!ShowMeter "Group1"] option perfectly works, while LeftMouseUpAction=[!Delay "150"] [!ShowMeter "Group1"] doesn't. So far couldn't find such problem on other bangs, but obviously I didn't test all of them.
I agree with you about the uselessness of those spaces, however this looks extremely weird to me so I recommended him to post this description here.
User avatar
Brian
Developer
Posts: 2272
Joined: November 24th, 2011, 1:42 am
Location: Utah

Re: [!Delay x] bug/glitch

Post by Brian »

Good catch everyone. This has been fixed for the next beta.

-Brian