It is currently December 3rd, 2020, 11:03 am

Unicode Character Reference In Metadata

Report bugs with the Rainmeter application and suggest features.
User avatar
Yincognito
Posts: 2934
Joined: February 27th, 2015, 2:38 pm
Location: Terra Yincognita

Unicode Character Reference In Metadata

Post by Yincognito »

Ok, so I'm "beautifying" my skins a little, by making their [Metadata] section more compact and easier to follow, and while using Unicode characters in the section (mainly U+2006 spaces, to "align" stuff in the proportional font used in the Manage Rainmeter window), I've encountered the following behavior...

1. Plain Unicode Characters:
Metadata Section - Unicode (plain character).jpg
2. Unicode Character Reference:
Metadata Section - Unicode (character reference).jpg
As you can see, case 1 works fine and the colons (:) properly display one below another in the Information area of the skin, but when switching to display the same characters by means of reference (i.e. [\x2006]) in case 2, the literal string is used instead of the referenced character.

Now, I'm not terribly bothered by this, but still it would be nice to use character references in the [Metadata] section as well, since they are easier to spot and displaying them in the editor doesn't depend on the font being used (and whether or not those characters are available in that said font), so I have to ask: is this the expected behavior, or those character references should be in fact work in that section but the area was "forgotten" when updating things after the introduction of the character reference feature in Rainmeter?

P.S. By the way, the deprecated Description and Instructions options from the [Metadata] section exhibit the same behavior.
You do not have the required permissions to view the files attached to this post.
User avatar
Brian
Developer
Posts: 2076
Joined: November 24th, 2011, 1:42 am
Location: Utah

Re: Unicode Character Reference In Metadata

Post by Brian »

Unfortunately, since the metadata section can be loaded without the skin being loaded, variable parsing won't work....at least without completely rewriting a portion of this code. I am not sure this is a high enough priority at the moment.

-Brian
User avatar
Yincognito
Posts: 2934
Joined: February 27th, 2015, 2:38 pm
Location: Terra Yincognita

Re: Unicode Character Reference In Metadata

Post by Yincognito »

Brian wrote: October 30th, 2020, 10:22 pm[...] since the metadata section can be loaded without the skin being loaded [...]
Yep, I suspected this was a possible particularity of the issue. Thanks for answering anyway - at least the plain character method is a workaround (which I used already, since posting this). :thumbup: