It is currently May 25th, 2019, 2:19 pm

[Bug/Maybe] Visualizer changed behavior in 4.3

Report bugs with the Rainmeter application and suggest features.
User avatar
virtual-adam
Posts: 7
Joined: February 11th, 2017, 9:32 pm
Location: UK

[Bug/Maybe] Visualizer changed behavior in 4.3

virtual-adam » March 20th, 2019, 9:45 am

The 4.3 update has changed my visualizer skin so that it shows the bottom pixel of the bars all the time.

Can i fix this by changing the code in the skin or is this a bug?

Thanks.
User avatar
jsmorley
Developer
Posts: 19245
Joined: April 19th, 2009, 11:02 pm
Location: Fort Hunt, Virginia, USA

Re: [Bug/Maybe] Visualizer changed behavior in 4.3

jsmorley » March 20th, 2019, 12:27 pm

I'm not getting that behavior with your visualizer skin.

https://forum.rainmeter.net/viewtopic.php?f=123&t=29068#p151613
User avatar
virtual-adam
Posts: 7
Joined: February 11th, 2017, 9:32 pm
Location: UK

Re: [Bug/Maybe] Visualizer changed behavior in 4.3

virtual-adam » March 20th, 2019, 7:59 pm

Thanks for the reply, it was a useless post :?

In 4.2 the bars would not leave a 1 pixel line at the bottom when there was no audio.

Rainmeter 4.3.0.3298 (64-bit)
Language: English (1033)
Build time: 2019-03-18 11:00:34
Commit Hash: 3593c281
Windows 7 Professional 64-bit (build 7601) Service Pack 1 - English (2057)
Path: C:\Program Files\Rainmeter\
SkinPath: C:\Users\Adam\Documents\Rainmeter\Skins\
SettingsPath: C:\Users\Adam\AppData\Roaming\Rainmeter\
IniFile: C:\Users\Adam\AppData\Roaming\Rainmeter\Rainmeter.ini

AMD Radeon R7 200 Series

.rmskin file attached...
You do not have the required permissions to view the files attached to this post.
User avatar
CyberTheWorm
Posts: 639
Joined: August 22nd, 2016, 11:32 pm
Location: Surrey, B.C., Canada

Re: [Bug/Maybe] Visualizer changed behavior in 4.3

CyberTheWorm » March 21st, 2019, 5:43 am

not a bug but bad code

MinBarValue=0 fixes it, having it MinBarValue=0.005 give a bar height to 1

Next you get an error loading the skin

Unable to read file: C:\Users\Graham\Documents\Rainmeter\Skins\Escape\Visualizer\@Resources\Variables.inc (Visualizer\Visualizer.ini)

change @include=#SKINSPATH#Visualizer\@Resources\Variables.inc to @include=#@#Variables.inc in all your files
The only source of knowledge is experience. Albert Einstein
Deviant Art Page
User avatar
virtual-adam
Posts: 7
Joined: February 11th, 2017, 9:32 pm
Location: UK

Re: [Bug/Maybe] Visualizer changed behavior in 4.3

virtual-adam » March 21st, 2019, 10:39 am

Thanks Cyber

The skin is pulled from a suite I'm working on so the unable to read error was my fault for missing an include line. Logs clean on my end.

Great thats fixed the bar lines, but I've also noticed their movement stutters and is not smooth like on 4.2. Guess changing some of the values in the BandMeasuresSmoothed will sort it out? I can have a play some time.

Cheers for your time :thumbup:
Last edited by virtual-adam on March 26th, 2019, 11:05 am, edited 2 times in total.
User avatar
virtual-adam
Posts: 7
Joined: February 11th, 2017, 9:32 pm
Location: UK

Re: [Bug/Maybe] Visualizer changed behavior in 4.3

virtual-adam » March 21st, 2019, 11:13 am

Forget the stuttering bar part, they seem fine now switching between 4.2 and 4.3.

All sorted!
Last edited by virtual-adam on March 26th, 2019, 11:01 am, edited 1 time in total.
User avatar
virtual-adam
Posts: 7
Joined: February 11th, 2017, 9:32 pm
Location: UK

Re: [Bug/Maybe] Visualizer changed behavior in 4.3

virtual-adam » March 25th, 2019, 2:43 pm

Having tested the visualizer out further I can see a change in the bar behavior from 4.2. It seems to have hesitation/stuttering in 4.3.
Last edited by virtual-adam on March 26th, 2019, 10:58 am, edited 1 time in total.
User avatar
virtual-adam
Posts: 7
Joined: February 11th, 2017, 9:32 pm
Location: UK

Re: [Bug/Maybe] Visualizer changed behavior in 4.3

virtual-adam » March 25th, 2019, 11:53 pm

I switched on 'Use hardware acceleration' in settings (as suggested in the release notes) and now its just as smooth as 4.2.