It is currently April 13th, 2021, 5:11 pm

HWiNFO GPU Skin

Skins that monitor system information
User avatar
jsmorley
Developer
Posts: 21619
Joined: April 19th, 2009, 11:02 pm
Location: Fort Hunt, Virginia, USA

HWiNFO GPU Skin

Post by jsmorley »

This skin uses the HWiNFO application and Rainmeter plugin to monitor information about your graphics card / GPU.

I have this configured for my card, an NVIDIA GeForce GTX 1660 Ti, but it can be altered to match the sensors for your card.

Get the HWiNFO application here:

https://www.hwinfo.com/

The Rainmeter plugin will be installed by the .rmskin.

HWiNFOgpu_1.2.rmskin

Right-click the skin to open the HWiNFO "Shared Memory Viewer", where you can get the values for the sensors for your system, and put them in HWiNFOVariables.inc.
4.jpg
1.jpg
5.jpg

3.jpg
2.jpg


Version 1.2 changes some cosmetics and automatically gets the card name.
Version 1.1 corrects an error in calculating the Bar gradients.
You do not have the required permissions to view the files attached to this post.
User avatar
jsmorley
Developer
Posts: 21619
Joined: April 19th, 2009, 11:02 pm
Location: Fort Hunt, Virginia, USA

Re: HWiNFO GPU Skin

Post by jsmorley »

Version 1.2 changes some cosmetics and automatically gets the card name.
Version 1.1 corrects an error in calculating the Bar gradients.


1.jpg
You do not have the required permissions to view the files attached to this post.
tsumihoroboshi
Posts: 3
Joined: March 28th, 2021, 1:51 pm

Re: HWiNFO GPU Skin

Post by tsumihoroboshi »

This has never worked for me. Any gpu plugin has never worked for me.
I have hwinfo v7.00 running with shared memory and rainmeter running as admin.
When I click "view Hwinfo sensors" in your skin it says "failed to connect to hwinfo", but hwinfo is running.

Even if it worked I don't understand why it does not use the nvidia dll's instead of having to keep a 3rd party app running on background.
User avatar
jsmorley
Developer
Posts: 21619
Joined: April 19th, 2009, 11:02 pm
Location: Fort Hunt, Virginia, USA

Re: HWiNFO GPU Skin

Post by jsmorley »

tsumihoroboshi wrote: March 28th, 2021, 2:01 pm This has never worked for me. Any gpu plugin has never worked for me.
I have hwinfo v7.00 running with shared memory and rainmeter running as admin.
When I click "view Hwinfo sensors" in your skin it says "failed to connect to hwinfo", but hwinfo is running.

Even if it worked I don't understand why it does not use the nvidia dll's instead of having to keep a 3rd party app running on background.
Be sure you have Shared Memory Support checked in the Settings dialog in order to use the old Shared Memory / Plugin approach.

1.png

I don't particularly recommend that however. I think you might want to see this:

https://forum.rainmeter.net/viewtopic.php?f=127&t=37160
You do not have the required permissions to view the files attached to this post.
tsumihoroboshi
Posts: 3
Joined: March 28th, 2021, 1:51 pm

Re: HWiNFO GPU Skin

Post by tsumihoroboshi »

yes , i'm sure
tsumihoroboshi
Posts: 3
Joined: March 28th, 2021, 1:51 pm

Re: HWiNFO GPU Skin

Post by tsumihoroboshi »

nvm I've modified a skin to make it work with UsageMonitor plugin.
https://www.deviantart.com/noelperal/art/GPU-Monitoring-for-CircuitousTwo-UsageMonitor-874626357