It is currently June 16th, 2021, 11:03 am

Game mode revisited

Changes made during the Rainmeter 4.4 beta cycle.
rick-t-fiedrain
Posts: 25
Joined: February 15th, 2014, 9:53 am

Re: Game mode revisited

Post by rick-t-fiedrain »

Is there a reason that I'm getting an

>> Initializing "Game Mode" (v1)

message in About Rainmeter (Debug Mode) when I've done nothing to engage game mode (at least that I'm aware of)? I did not see any references to this kind of thing when I skimmed through the docs / posts about game mode.

Here is the view from "About Rainmeter"
game mode initialized.png
And this is what my game mode tab looks like in the Rainmeter Manager.
game mode tab.png
The google news skin and a personal refresh of 'the professional' (created before game mode was born) are the only two items running.

It's probably something I've done .. but don't realize it. Any help appreciated.

RICK
You do not have the required permissions to view the files attached to this post.
User avatar
Yincognito
Posts: 3184
Joined: February 27th, 2015, 2:38 pm
Location: Terra Yincognita

Re: Game mode revisited

Post by Yincognito »

rick-t-fiedrain wrote: May 19th, 2021, 6:12 pmIt's probably something I've done .. but don't realize it.
I don't think it's anything you've done. My guess is that it's a normal Debug Mode log message, pretty much like the messages detecting system configuration details. I'm getting this too when I check Debug Mode in Rainmeter's Settings, and I'm pretty sure nothing is "wrong" or anything like that.

Unchecking Debug Mode in Settings will probably prevent this log message from showing up. There is also a C:\Users\[User]\AppData\Roaming\Rainmeter\Rainmeter.data file on the hard drive that's most likely related to the Game Mode operations (you can see similar messages there if you open it with Notepad and such).

The developers would be able to offer more details on the matter, but I don't think they'll be too concerned about it, since the message, apart from the slightly different format compared to others, seems to be both normal and harmless.
User avatar
Brian
Developer
Posts: 2140
Joined: November 24th, 2011, 1:42 am
Location: Utah

Re: Game mode revisited

Post by Brian »

rick-t-fiedrain wrote: May 19th, 2021, 6:12 pm Is there a reason that I'm getting an
Yincognito is correct, this is just an a simple debug "informational" type of message letting the user know that game mode is available and which settings version it is using (in case we change things down the road).

There is nothing to worry about.

Also, when game mode is started/stopped, you will see a regular "Notice" message in the log.

-Brian

BTW - There is a typo in the word "Initializing" that will be fixed in the next beta.