It is currently September 24th, 2020, 5:20 am

Plugin for SIV

Share and get help with Plugins and Addons
User avatar
StArL0rd84
Posts: 348
Joined: February 8th, 2015, 10:07 pm
Location: EU, Denmark.

Re: Plugin for SIV

Post by StArL0rd84 »

Is this a bug?
Reading from the Heading sensor group crashes Rainmeter.

Code: Select all

[mGPU_Name]
 Measure=Plugin
 Plugin=SIV
 SivKey=GPU-0-NAM
 Sensor=H
(#WorkTime# = 1 ? #Work# : ([mEnergyLoss:%] > 100 ? #SleepMode# : #Rainmeter#))
User avatar
eclectic-tech
Rainmeter Sage
Posts: 4114
Joined: April 12th, 2012, 9:40 pm
Location: Cedar Point, Ohio, USA

Re: Plugin for SIV

Post by eclectic-tech »

StArL0rd84 wrote:Is this a bug?
Reading from the Heading sensor group crashes Rainmeter.

Code: Select all

[mGPU_Name]
 Measure=Plugin
 Plugin=SIV
 SivKey=GPU-0-NAM
 Sensor=H
I didn't experience a crash, but it logged an error "failed to read the value..."

All items should have 'SIV' prefix... SIVSensor

Code: Select all

[mGPU_Name]
 Measure=Plugin
 Plugin=SIV
 SivKey=GPU-0-NAM
 SIVSensor=H
That change removed the error msg, but also showed me a number instead of the GPU name??
User avatar
StArL0rd84
Posts: 348
Joined: February 8th, 2015, 10:07 pm
Location: EU, Denmark.

Re: Plugin for SIV

Post by StArL0rd84 »

eclectic-tech wrote:All items should have 'SIV' prefix... SIVSensor
That change removed the error msg, but also showed me a number instead of the GPU name??
Yup, something weird is going on, OP should look into this.
Got the GPU name from the registry in stead:

Code: Select all

[GPU_NAME]
Measure=Registry
RegHKey=HKEY_LOCAL_MACHINE
RegKey=SOFTWARE\Microsoft\Windows NT\CurrentVersion\WinSat
RegValue=PrimaryAdapterString 
https://forum.rainmeter.net/viewtopic.php?p=123988#p123988
(#WorkTime# = 1 ? #Work# : ([mEnergyLoss:%] > 100 ? #SleepMode# : #Rainmeter#))
User avatar
StArL0rd84
Posts: 348
Joined: February 8th, 2015, 10:07 pm
Location: EU, Denmark.

Re: Plugin for SIV

Post by StArL0rd84 »

Getting a weird error in the log:
Could not load library user32.dll for some unknown reason.
(#WorkTime# = 1 ? #Work# : ([mEnergyLoss:%] > 100 ? #SleepMode# : #Rainmeter#))
pmilano1
Posts: 1
Joined: September 3rd, 2020, 12:51 pm

Re: Plugin for SIV

Post by pmilano1 »

Is the code in a repo somewhere?

I've updates SIV to 5.51 and can't seem to get the plugin working again.