It is currently August 20th, 2019, 3:10 pm

[D2D][Fixed] UseExifOrientation not working

Backwards compatibility issues related to the conversion of Rainmeter to D2D.
mochibear
Posts: 45
Joined: June 3rd, 2014, 11:16 pm

Re: [BUG?] UseExifOrientation not working

mochibear » January 19th, 2019, 8:20 pm

balala wrote:
January 19th, 2019, 8:11 pm
Your code works perfectly for me and it does what it should: when double clicking the image, explorer opens and the current image is highlighted.
Try eventually to run a such command in command line, to see how does it work there. Open a command line and enter this: explorer /select,-COMPLET PATH OF AN IMAGE-. Does the explorer open, with the image highlighted?
What Windows version are you using?

In cmd line this worked for me

Code: Select all

explorer /select, "D:\Applications\Rainmeter\Skins\Pictures (with thin Frame)\Background.png"

I think it's because there's spaces in the directory? I don't know how I would fix that in the rainmeter script.

edit: wth? I don't know what happened or what I changed but it seems to be working now. In hindsight, double click to open directory was a stupid idea on my part because it sometimes skips to the next picture and loads that one. What about control clicking? Or any other key combination you recommend?
User avatar
balala
Rainmeter Sage
Posts: 8534
Joined: October 11th, 2010, 6:27 pm
Location: Gheorgheni, Romania

Re: [BUG?] UseExifOrientation not working

balala » January 19th, 2019, 8:54 pm

mochibear wrote:
January 19th, 2019, 8:20 pm
edit: wth? I don't know what happened or what I changed but it seems to be working now. In hindsight, double click to open directory was a stupid idea on my part because it sometimes skips to the next picture and loads that one. What about control clicking? Or any other key combination you recommend?
I'm glad if you got it working well.
Yes, LeftMouseDoubleClickAction is a bad workaround in this case. I'd use instead a RightMouseUpAction: RightMouseUpAction=[!CommandMeasure "MeasureRun" "Run"].
Eventually if you'll have any other issues, try to quote the measure name into the Parameter option of [MeasureRun] measure: Parameter=explorer /select,"[MeasureMyPictures]"
mochibear
Posts: 45
Joined: June 3rd, 2014, 11:16 pm

Re: [BUG?] UseExifOrientation not working

mochibear » January 19th, 2019, 9:03 pm

Rightmouseaction works beautifully.

Gosh, Ty so much Brian and Balala for all your help! I love this app and will spread the message
User avatar
balala
Rainmeter Sage
Posts: 8534
Joined: October 11th, 2010, 6:27 pm
Location: Gheorgheni, Romania

Re: [BUG?] UseExifOrientation not working

balala » January 19th, 2019, 9:21 pm

mochibear wrote:
January 19th, 2019, 9:03 pm
I love this app
Me too. :thumbup:
mochibear wrote:
January 19th, 2019, 9:03 pm
will spread the message
Do it. :great: