It is currently December 10th, 2018, 6:36 pm

[Solved] BackgroundMode = 2 is broken.

Testing and discussion of the conversion of Rainmeter to D2D.
AlphaGamer150
Posts: 9
Joined: September 11th, 2018, 6:46 pm

[Solved] BackgroundMode = 2 is broken.

AlphaGamer150 » September 15th, 2018, 11:24 am

Image
Rainmeter 4.3.0.3249 beta (64-bit)
Language: English (1033)
Build time: 2018-09-13 9:33:50
Commit Hash: 996ebcc0
Windows 10 Home 1803 64-bit (build 17134) - English (2057)
Path: C:\Program Files\Rainmeter\
SkinPath: C:\Users\peter\Documents\Rainmeter\Skins\
SettingsPath: C:\Users\peter\AppData\Roaming\Rainmeter\
IniFile: C:\Users\peter\AppData\Roaming\Rainmeter\Rainmeter.ini
Intel(R) HD Graphics 520
You do not have the required permissions to view the files attached to this post.
Last edited by AlphaGamer150 on September 15th, 2018, 2:09 pm, edited 3 times in total.
User avatar
jsmorley
Developer
Posts: 18445
Joined: April 19th, 2009, 11:02 pm
Location: Fort Hunt, Virginia, USA

Re: BackgroundMode = 2 is broken.

jsmorley » September 15th, 2018, 11:46 am

Thanks. We are aware that there is an issue with some Intel HD (Integrated graphics chips) graphics due to a bug in drivers from Intel. It is our understanding, from testing various users have done, that updating your drivers to the very latest release from Intel corrects this issue.

https://downloadcenter.intel.com/product/88355/Intel-HD-Graphics-520

The other alternative you can try is to turn off Hardware Acceleration in the Settings panel in Rainmeter.
1.jpg
Let us know if either or both of these suggestions solves the problem for you.
You do not have the required permissions to view the files attached to this post.
AlphaGamer150
Posts: 9
Joined: September 11th, 2018, 6:46 pm

Re: BackgroundMode = 2 is broken.

AlphaGamer150 » September 15th, 2018, 2:06 pm

After updating the graphics drivers, the skin is now working perfectly.
User avatar
jsmorley
Developer
Posts: 18445
Joined: April 19th, 2009, 11:02 pm
Location: Fort Hunt, Virginia, USA

[Solved] BackgroundMode = 2 is broken.

jsmorley » September 15th, 2018, 2:52 pm

Outstanding. Thanks for reporting and letting us know that updating the drivers worked.