It is currently December 10th, 2018, 6:39 pm

[Solved] Visual glitch with acceleration on

Testing and discussion of the conversion of Rainmeter to D2D.
User avatar
Active Colors
Moderator
Posts: 498
Joined: February 16th, 2012, 3:32 am

[Solved] Visual glitch with acceleration on

Active Colors » August 24th, 2018, 5:08 am

Strange visual glitch is occuring on changing ImageAlpha on meters. It is happening with acceleration turned on in 4.3 r3237.

How it works in 4.2 r3111:
gif1.gif
(click to animate)

How it is working in 4.3 r3237
gif3.gif
(click to animate)

The glitch does not seem to appear with turned off D2D as can be observed here.

Code: Select all

Rainmeter 4.3.0.3237 beta (64-bit)
Language: English (1033)
Build time: 2018-08-23 16:00:46
Commit Hash: e1040980
Windows 7 Professional 64-bit (build 7601) Service Pack 1 - English (1033)
Path: C:\Program Files\Rainmeter\
SkinPath: D:\#Profiles\Active Colors\Rainmeter\Skins\
SettingsPath: C:\Users\User\AppData\Roaming\Rainmeter\
IniFile: C:\Users\User\AppData\Roaming\Rainmeter\Rainmeter.ini
You do not have the required permissions to view the files attached to this post.
User avatar
jsmorley
Developer
Posts: 18445
Joined: April 19th, 2009, 11:02 pm
Location: Fort Hunt, Virginia, USA

Re: Visual glitch with D2D

jsmorley » August 24th, 2018, 11:51 am

Where is the .rmskin of this example skin?
User avatar
Active Colors
Moderator
Posts: 498
Joined: February 16th, 2012, 3:32 am

Re: Visual glitch with D2D

Active Colors » August 25th, 2018, 3:52 am

jsmorley wrote:Where is the .rmskin of this example skin?
Stripped off the skin to the bare minimum to demonstrate the problem.
GlitchTest_1.0.rmskin
Comparison:

4.2 r3111:
GIF1.gif
4.3 r3237:
GIF2.gif
You do not have the required permissions to view the files attached to this post.
User avatar
Brian
Developer
Posts: 1793
Joined: November 24th, 2011, 1:42 am
Location: Utah

Re: Visual glitch with acceleration on

Brian » August 25th, 2018, 5:51 am

Hmmmm. I am not getting that at all.

Here is what I get:
GlitchTest.gif
Left is 4.2, Right is 4.3

I wonder if this is an issue with certain graphics cards and/or graphics drivers. Feels similar to this: https://forum.rainmeter.net/viewtopic.php?p=151598#p151598

-Brian
You do not have the required permissions to view the files attached to this post.