It is currently October 23rd, 2020, 10:46 am

[D2D][Resolved] Visual glitch with acceleration on

Backwards compatibility issues related to the conversion of Rainmeter to D2D.
User avatar
Active Colors
Moderator
Posts: 618
Joined: February 16th, 2012, 3:32 am

[D2D][Resolved] Visual glitch with acceleration on

Post by Active Colors »

Strange visual glitch is occuring on changing ImageAlpha on meters. It is happening with acceleration turned on in 4.3 r3237.

How it works in 4.2 r3111:
gif1.gif
(click to animate)

How it is working in 4.3 r3237
gif3.gif
(click to animate)

The glitch does not seem to appear with turned off D2D as can be observed here.

Code: Select all

Rainmeter 4.3.0.3237 beta (64-bit)
Language: English (1033)
Build time: 2018-08-23 16:00:46
Commit Hash: e1040980
Windows 7 Professional 64-bit (build 7601) Service Pack 1 - English (1033)
Path: C:\Program Files\Rainmeter\
SkinPath: D:\#Profiles\Active Colors\Rainmeter\Skins\
SettingsPath: C:\Users\User\AppData\Roaming\Rainmeter\
IniFile: C:\Users\User\AppData\Roaming\Rainmeter\Rainmeter.ini
You do not have the required permissions to view the files attached to this post.
User avatar
jsmorley
Developer
Posts: 21424
Joined: April 19th, 2009, 11:02 pm
Location: Fort Hunt, Virginia, USA

Re: Visual glitch with D2D

Post by jsmorley »

Where is the .rmskin of this example skin?
User avatar
Active Colors
Moderator
Posts: 618
Joined: February 16th, 2012, 3:32 am

Re: Visual glitch with D2D

Post by Active Colors »

jsmorley wrote:Where is the .rmskin of this example skin?
Stripped off the skin to the bare minimum to demonstrate the problem.
GlitchTest_1.0.rmskin
Comparison:

4.2 r3111:
GIF1.gif
4.3 r3237:
GIF2.gif
You do not have the required permissions to view the files attached to this post.
User avatar
Brian
Developer
Posts: 2067
Joined: November 24th, 2011, 1:42 am
Location: Utah

Re: Visual glitch with acceleration on

Post by Brian »

Hmmmm. I am not getting that at all.

Here is what I get:
GlitchTest.gif
Left is 4.2, Right is 4.3

I wonder if this is an issue with certain graphics cards and/or graphics drivers. Feels similar to this: https://forum.rainmeter.net/viewtopic.php?p=151598#p151598

-Brian
You do not have the required permissions to view the files attached to this post.
User avatar
Active Colors
Moderator
Posts: 618
Joined: February 16th, 2012, 3:32 am

Re: [D2D][Resolved] Visual glitch with acceleration on

Post by Active Colors »

The problem is gone after reinstalling Windows.
User avatar
Active Colors
Moderator
Posts: 618
Joined: February 16th, 2012, 3:32 am

Re: [D2D][Resolved] Visual glitch with acceleration on

Post by Active Colors »

Found the culprit. After installing either Steam, or a game from steam, or SageThumbs, I got this setting changed shown on the screenshot below. Be sure not to have "High Performance NVIDIA" with Rainmeter, in case if such bug happens to you. I will remind, I have:

Code: Select all

Windows 7 Professional 64-bit
Dell Inspirion 5558
NVIDIA GeForce 920M 
Intel Core i5-5200U
Capture.PNG
You do not have the required permissions to view the files attached to this post.