It is currently August 11th, 2020, 6:47 pm

Weather.com JSON not loading correctly

General topics related to Rainmeter.
User avatar
jsmorley
Developer
Posts: 21240
Joined: April 19th, 2009, 11:02 pm
Location: Fort Hunt, Virginia, USA

Weather.com JSON not loading correctly

Post by jsmorley »

Recently there has been an issue where weather.com is passing some kind of bad data or cookie that is causing a problem with the Internet Explorer API calls that WebParser uses to access the web.

If you run into this, we have found that doing the following will correct it, as least it has so far...

1) Completely exit Rainmeter


2) Clean the IE cache and cookies using the following approach:




3) Wait about one minute, then restart Rainmeter.
Wim
Posts: 55
Joined: September 22nd, 2010, 8:30 pm

Re: ⭐ Weather.com JSON not loading correctly

Post by Wim »

Thnx. It worked for me.
User avatar
balala
Rainmeter Sage
Posts: 11199
Joined: October 11th, 2010, 6:27 pm
Location: Gheorgheni, Romania

Re: ⭐ Weather.com JSON not loading correctly

Post by balala »

But this issue is related only to skins using weather.com? I mean that if I'm using some skins with WebParser measures which don't parse weather.com, can't the same problem arise?
Would be weird...
User avatar
SilverAzide
Posts: 928
Joined: March 23rd, 2015, 5:26 pm

Re: ⭐ Weather.com JSON not loading correctly

Post by SilverAzide »

Up until today I have not experienced this issue. Now I have it and clearing the cache/cookies isn't working for me. I'm getting the JSON data, but in a completely different format. :(
Gadgets DeviantArt More...
User avatar
jsmorley
Developer
Posts: 21240
Joined: April 19th, 2009, 11:02 pm
Location: Fort Hunt, Virginia, USA

Re: ⭐ Weather.com JSON not loading correctly

Post by jsmorley »

SilverAzide wrote: May 26th, 2020, 7:52 pm Up until today I have not experienced this issue. Now I have it and clearing the cache/cookies isn't working for me. I'm getting the JSON data, but in a completely different format. :(
Be sure you follow the first post in this thread exactly.
dvo
Posts: 886
Joined: February 7th, 2016, 6:08 am

Re: ⭐ Weather.com JSON not loading correctly

Post by dvo »

just clean your IE temp and cache and refresh your skin a couple of times after the cleaning...
ps. it will be back in a few days... and you have to do it again...
User avatar
SilverAzide
Posts: 928
Joined: March 23rd, 2015, 5:26 pm

Re: ⭐ Weather.com JSON not loading correctly

Post by SilverAzide »

jsmorley wrote: May 26th, 2020, 8:28 pm Be sure you follow the first post in this thread exactly.
Yep, I did... I even rebooted before restarting Rainmeter just in case. I'm getting the JSON, but it's in a completely different format. The "units" section is missing, the "location" section is there but the regexp is failing due to a missing term, the "current conditions" section is there but with slightly different names, and the forecast comes in two chunks (7-day and 14-day), and all the values are in 7- and 14- element arrays. Grr. I tried a different user agent string (just in case) and still got the same results.

I'll send you the "EntireSite.txt" file if you want to check it out for yourself.
Gadgets DeviantArt More...
User avatar
pul53dr1v3r
Posts: 399
Joined: July 30th, 2014, 10:30 am

Re: ⭐ Weather.com JSON not loading correctly

Post by pul53dr1v3r »

User avatar
SilverAzide
Posts: 928
Joined: March 23rd, 2015, 5:26 pm

Re: ⭐ Weather.com JSON not loading correctly

Post by SilverAzide »

pul53dr1v3r wrote: May 26th, 2020, 8:55 pm https://forum.rainmeter.net/viewtopic.php?f=27&t=34734&start=150#p177080 (mostly for Windows 10).
OK, your step #3 is what finally worked for me (I cannot use CCleaner [site blocked by corporate policy], so I could only do step #1). After clearing everything, going into Settings and "View files" STILL showed files remaining. Did a Ctrl-A to select everything then Delete, then restarted Rainmeter and -- taadaa -- it worked.

Thanks! :)
Gadgets DeviantArt More...
mak_kawa
Posts: 774
Joined: December 30th, 2015, 9:47 am

Re: ⭐ Weather.com JSON not loading correctly

Post by mak_kawa »

Hi everyone

I feel really weird... This morning I too encountered this issue on scraping Weather.com. Checking the html source, I have found that the source syntax/contents is completely different from previous one. Why?! It is natural that the RegExp error has occurred.

Following jsmorley and pul53dr1v3r's instruction, I doubtfully cleared cookies on *Internet Explorer 11* (!). I am not using IE11 since two or three years ago. And... surprisingly the issue is gone!.
I am not sure why clearing the cookie for IE11 can solve the issue on my weather skin... One thing I can guess is that "the WebParser measure uses IE11 components", am I right?

If so, I am a bit anxious that Rainmeter uses obsolete(?) components for the important and indispensable WebParser measure... Is there a possibility that IE11 and its components will be removed completely from Windows10 (or later version)??