It is currently March 24th, 2019, 10:43 pm

Fix for AudioLevel plugin

Changes made during the Rainmeter 3.2 beta cycle.
User avatar
jsmorley
Developer
Posts: 19076
Joined: April 19th, 2009, 11:02 pm
Location: Fort Hunt, Virginia, USA

Fix for AudioLevel plugin

jsmorley » March 9th, 2015, 1:44 pm

We have corrected a long standing issue with the AudioLevel plugin, where stopping music or a sound or exiting an application playing music or a sound could cause the plugin to keep the last values it received, in effect "freezing" the meter display, and on some systems creating a "buzzing" sound for some number of milliseconds.

Please test this out this week, so we can be sure it corrects the issue for everyone, and that there are no unintended consequences.

You can test by loading any AudioLevel plugin skin, and opening a .mp3 song in VLC, WinAmp, or your media player of choice. Don't have any other applications making any sound at the same time. While the song is playing test both "stopping" the song in the player, and "exiting" the player application in mid-song. Be sure the AudioLevel plugin properly decays to a zero value, and your meters respond.
User avatar
dgrace
Developer
Posts: 265
Joined: June 28th, 2014, 8:32 am
Location: Tokyo, Japan

Re: Fix for AudioLevel plugin

dgrace » March 9th, 2015, 9:47 pm

Just for the sake of accuracy, the bug wasn't in the AudioLevel plugin - it's in Windows. I just added a workaround in the plugin. ;)

dave
User avatar
jsmorley
Developer
Posts: 19076
Joined: April 19th, 2009, 11:02 pm
Location: Fort Hunt, Virginia, USA

Re: Fix for AudioLevel plugin

jsmorley » March 9th, 2015, 10:25 pm

dgrace wrote:Just for the sake of accuracy, the bug wasn't in the AudioLevel plugin - it's in Windows. I just added a workaround in the plugin. ;)

dave
Fair enough. Let's be accurate. I changed that term everywhere.
User avatar
StArL0rd84
Posts: 301
Joined: February 8th, 2015, 10:07 pm
Location: EU, Denmark.

Re: Fix for AudioLevel plugin

StArL0rd84 » March 24th, 2015, 10:40 pm

Totally works now, well for me at least.
The "buzzing" sound is gone it seems.
Great job :thumbup: