It is currently April 12th, 2021, 4:09 am

GBU METER shows only zero for RAM

Get help with installing and using Rainmeter.
dippess
Posts: 3
Joined: March 10th, 2021, 11:11 am

GBU METER shows only zero for RAM

Post by dippess »

Hello

Hello
I have a GeForce GTX 1050 TI, all data is displayed except RAM (see screenshot).
The skin is from "SilverAzide".
What must be changed in the HWINFO settings ?


Image
User avatar
SilverAzide
Rainmeter Sage
Posts: 1203
Joined: March 23rd, 2015, 5:26 pm

Re: GBU METER shows only zero for RAM

Post by SilverAzide »

dippess wrote: March 10th, 2021, 11:45 am Hello
I have a GeForce GTX 1050 TI, all data is displayed except RAM (see screenshot).
The skin is from "SilverAzide".
What must be changed in the HWINFO settings ?
There are two settings for RAM for your nVidia GPU, one for the amount of memory allocated, another for the percentage of the total memory in use:

Code: Select all

; GPU memory usage (percent)
;   NOTE: for nVidia GPUs ONLY, this sensor reports the percentage of RAM in use
HWiNFO-GPU0-MemoryUsage=0x???????
; GPU memory allocated (MB)
;   NOTE: for nVidia GPUs, set the following value to the ID of the "GPU Memory Allocated" sensor (i.e., amount of VRAM allocated, in megabytes)
HWiNFO-GPU0-MemoryAlloc=0x???????
If you have multiple GPUs (for example, a built-in Intel GPU), take care to update the settings for the proper GPU number. Also double-check that the sensor ID and Sensor Instance values match what you have (don't assume the default will work).

Also, see this: Public Service Announcement: Upgrading to HWiNFO 7.0
Gadgets Wiki GitHub More Gadgets...
dippess
Posts: 3
Joined: March 10th, 2021, 11:11 am

Re: GBU METER shows only zero for RAM

Post by dippess »

HWiNFO-GPU0-MemoryAlloc= I have corrected and is displayed in the skin under "used".is this correct?

HWiNFO-GPU0-MemoryUsage= does not exist in the HWINFO Shared Memory Viewer.


Image
User avatar
SilverAzide
Rainmeter Sage
Posts: 1203
Joined: March 23rd, 2015, 5:26 pm

Re: GBU METER shows only zero for RAM

Post by SilverAzide »

dippess wrote: March 12th, 2021, 11:39 am HWiNFO-GPU0-MemoryAlloc= I have corrected and is displayed in the skin under "used".is this correct?

HWiNFO-GPU0-MemoryUsage= does not exist in the HWINFO Shared Memory Viewer.
Yes, the "Used" value does appear correct now. As far as the memory usage entry ID, it is definitely there; I've never seen it NOT there on an nVidia GPU. It might be called something slightly different, but it has to be there. Make sure you are not accidently looking at the Intel GPU (if you have one).
Screenshot 2021-03-12 083549.png
P.S.: Don't confuse the skin's variable names (i.e., "HWiNFO-GPU0-MemoryUsage") with the "Entry Name" you see in the Shared Memory Viewer ("GPU Memory Usage"). They are not intended to be an exact match, because the names vary from one GPU make/model to the next.
You do not have the required permissions to view the files attached to this post.
Gadgets Wiki GitHub More Gadgets...
dippess
Posts: 3
Joined: March 10th, 2021, 11:11 am

Re: GBU METER shows only zero for RAM

Post by dippess »

These are all the sensors I have available from my Nvidia.
Is there something suitable?



Image

Image

Image
User avatar
SilverAzide
Rainmeter Sage
Posts: 1203
Joined: March 23rd, 2015, 5:26 pm

Re: GBU METER shows only zero for RAM

Post by SilverAzide »

dippess wrote: March 13th, 2021, 8:23 am These are all the sensors I have available from my Nvidia.
Is there something suitable?
Uhh... wow. OK, you're right, it is missing. Well, you are the first person I've ever come across with this issue... lucky you!

What version of HWiNFO are you using? (You don't need v7.x, but 6.x versions should be OK.)
And are you using the latest nVidia drivers?
Also, if you open Task Manager and go to the Performance tab and select your nVidia GPU, what does Task manager show for "Dedicated GPU memory"?

If your drivers are up to date and HWiNFO reasonably so, then we'll need to adapt the AMD-style logic to your situation. (AMD GPUs do not report the percentage of RAM in use either.) To do this:
  1. Open the GPU Settings and click the Edit HWiNFO Settings option.
  2. Find the variable HWiNFO-GPU0-MemoryUsage and set the value to 0x0: HWiNFO-GPU0-MemoryUsage=0x0.
  3. Find the variable GPU0-MemoryTotal and set the value to the amount of VRAM on your video card, in megabytes. For example, if your card has 4GB of RAM, use GPU0-MemoryTotal=4096.
  4. Repeat for your other nVidia GPUs, if any.
  5. Save the file and click the Refresh button (blue arrows icon).
You should now see the proper free/total VRAM values.
Gadgets Wiki GitHub More Gadgets...