It is currently October 15th, 2019, 4:53 am

Visualizer won't work with DAW

Get help with installing and using Rainmeter.
Alexduvall
Posts: 2
Joined: May 27th, 2019, 11:33 pm

Visualizer won't work with DAW

Alexduvall » May 27th, 2019, 11:48 pm

So Rainmeter visualizers works fine with every application for me, aside from my recording software (Studio One 3). I'd really like the visualizers to play along when I make music, but it won't pick up the audio at all, even though it's coming through the speakers and everything else. I have an audio interface and it's set as my default driver for all audio, so it should pick it up, since that's also what studio one uses. I've looked around to see if I could find anything on this issue and no one's talked about it, so I thought I'd try here.
I don't have exclusive control set on the properties for the driver either, so I don't think that could be it.
If anyone could help with this issue that would be great, thank you.
User avatar
eclectic-tech
Rainmeter Sage
Posts: 3568
Joined: April 12th, 2012, 9:40 pm
Location: Cedar Point, Ohio, USA

Re: Visualizer won't work with DAW

eclectic-tech » May 28th, 2019, 12:56 am

Are you seeing any error messages in the Rainmeter log for the visualizer skin?
To view the log, select "Open log" from the MANAGE dialog or select "About" from the context menu.

Most audio enhancement software I have seen take exclusive control of the audio (even if the driver is set to prevent that in Windows) and will generate an error "Unable to initialize..." in the log. If you see that error, I do not think you are going to be able to use your studio software and have visualizers working at the same time.
Alexduvall
Posts: 2
Joined: May 27th, 2019, 11:33 pm

Re: Visualizer won't work with DAW

Alexduvall » May 28th, 2019, 1:52 am

So I checked the log, but I didn't see any error messages, other than an update error but I don't think that would have anything to do with audio right?
User avatar
eclectic-tech
Rainmeter Sage
Posts: 3568
Joined: April 12th, 2012, 9:40 pm
Location: Cedar Point, Ohio, USA

Re: Visualizer won't work with DAW

eclectic-tech » May 28th, 2019, 3:26 am

Alexduvall wrote:
May 28th, 2019, 1:52 am
So I checked the log, but I didn't see any error messages, other than an update error but I don't think that would have anything to do with audio right?
Probably not...

Not seeing any error messages regarding the audio client is a good thing, but being unfamiliar with your software, I can't really say why visualizers are not responding when using it.