It is currently September 21st, 2021, 6:02 pm

3.2.0.2326 or higher required to install...

Get help with installing and using Rainmeter.
CatNCobra
Posts: 22
Joined: August 3rd, 2014, 3:10 am

3.2.0.2326 or higher required to install...

Post by CatNCobra »

When I try to install skins that require the most current beta version, or possibly anything 3.2 and up (hard to say), I get an error from the installer saying:

"Rainmeter 3.2.0.2326 or higher is required to install this package.Get the latest version from rainmeter.net and try again."

Curiously (and annoyingly) enough, that's the version I have. Check the attached pictures if you think I'm crazy. Any help figuring out why would be greatly appreciated.

Thanks in advance,
-CNC
You do not have the required permissions to view the files attached to this post.
Last edited by CatNCobra on January 24th, 2015, 8:01 pm, edited 1 time in total.
User avatar
jsmorley
Developer
Posts: 22290
Joined: April 19th, 2009, 11:02 pm
Location: Fort Hunt, Virginia, USA

Re: 3.2.0.2326 or higher required to install...

Post by jsmorley »

Feels to me like your Windows "account" does not grant permission to SkinInstaller.exe to get the file "properties" from Rainmeter.dll, so it isn't able to properly detect the version of Rainmeter you are running.

Try going to the properties of C:\Program Files\Rainmeter\SkinInstaller.exe and set it to run "As administrator".
1.png
You do not have the required permissions to view the files attached to this post.
User avatar
jsmorley
Developer
Posts: 22290
Joined: April 19th, 2009, 11:02 pm
Location: Fort Hunt, Virginia, USA

Re: 3.2.0.2326 or higher required to install...

Post by jsmorley »

There may be some issue with running a 32bit Rainmeter (why??? Did you just copy the entire thing over from a 32bit Windows install or something?) on a 64bit Windows that might need looking at.
CatNCobra
Posts: 22
Joined: August 3rd, 2014, 3:10 am

Re: 3.2.0.2326 or higher required to install...

Post by CatNCobra »

No change unfortunately :/
jsmorley wrote:There may be some issue with running a 32bit Rainmeter (why??? Did you just copy the entire thing over from a 32bit Windows install or something?) on a 64bit Windows that might need looking at.
Hmmmm, never even noticed. I only got the current beta version a few days ago. Just downloaded from the home page and it never asked, so I never even thought of it. Give me a sec to check it out.
Last edited by CatNCobra on January 24th, 2015, 7:20 pm, edited 1 time in total.
CatNCobra
Posts: 22
Joined: August 3rd, 2014, 3:10 am

Re: 3.2.0.2326 or higher required to install...

Post by CatNCobra »

Just double checked, but it doesn't ask which version 32/64bits to install either. Is there a specific download for 64 bit version I can't find, or do I have to completely uninstall rainmeter at this point and reinstall from scratch? I've just been overlapping installed version since forever. Not sure if that makes a difference at all?
User avatar
jsmorley
Developer
Posts: 22290
Joined: April 19th, 2009, 11:02 pm
Location: Fort Hunt, Virginia, USA

Re: 3.2.0.2326 or higher required to install...

Post by jsmorley »

CatNCobra wrote:Just double checked, but it doesn't ask which version 32/64bits to install either. Is there a specific download for 64 bit version I can't find, or do I have to completely uninstall rainmeter at this point and reinstall from scratch? I've just been overlapping installed version since forever. Not sure if that makes a difference at all?
It shouldn't matter, but I think that might be worth doing. If you EVER installed a 32bit version of Rainmeter, it may well be detecting that and just continuing to install 32bit. A really clean install might help.

There is only one version of the installer for both. It checks what bit version is already installed and uses that, OR asks you.

I think it is going to be good to eliminate this conflict from the mix. Since presumably both SkinInstaller.exe and Rainmeter.exe are 32bit in your case, it shouldn't cause a bunch of issues to run 32bit Rainmeter on 64bit Windows, but I'd like to start eliminating stuff... Get down to Sherlock Holmes' famous "whatever is left..."
User avatar
balala
Rainmeter Sage
Posts: 13212
Joined: October 11th, 2010, 6:27 pm
Location: Gheorgheni, Romania

Re: 3.2.0.2326 or higher required to install...

Post by balala »

Maybe you should download an older skin, which requires an older Rainmeter version, to see if the issue still persists. Try this: http://rainmeter.net/forum/viewtopic.php?f=27&t=17138&p=94862#p94862. Requires at least Rainmeter 3.0.0.2085. Could it help?
CatNCobra
Posts: 22
Joined: August 3rd, 2014, 3:10 am

Re: 3.2.0.2326 or higher required to install...

Post by CatNCobra »

jsmorley wrote: It shouldn't matter, but I think that might be worth doing. If you EVER installed a 32bit version of Rainmeter, it may well be detecting that and just continuing to install 32bit. A really clean install might help.

There is only one version of the installer for both. It checks what bit version is already installed and uses that, OR asks you.

I'm not sure I see why this conflict would cause SkinInstaller to get hinky, but I think it is going to be good to eliminate this from the mix.
Well, that worked. Like you said, not sure what effect that really would have had, especially when skins specifically are labeled as having been tested on both 32 and 64 bit. Odd, but at least it's taken care of. Appreciate you hanging in there and helping me sort things out jsmorley!
CatNCobra
Posts: 22
Joined: August 3rd, 2014, 3:10 am

Re: 3.2.0.2326 or higher required to install...

Post by CatNCobra »

balala wrote:Maybe you should download an older skin, which requires an older Rainmeter version, to see if the issue still persists. Try this: http://rainmeter.net/forum/viewtopic.php?f=27&t=17138&p=94862#p94862. Requires at least Rainmeter 3.0.0.2085. Could it help?
Had already been using older skins. It only happened to be an issue with skins requiring the 3.2 or greater updated versions of rainmeter.
User avatar
jsmorley
Developer
Posts: 22290
Joined: April 19th, 2009, 11:02 pm
Location: Fort Hunt, Virginia, USA

Re: 3.2.0.2326 or higher required to install...

Post by jsmorley »

CatNCobra wrote: Well, that worked. Like you said, not sure what effect that really would have had, especially when skins specifically are labeled as having been tested on both 32 and 64 bit. Odd, but at least it's taken care of. Appreciate you hanging in there and helping me sort things out jsmorley!
Glad to help. We will have to chew on that a bit to see if we have some hidden nook or cranny that some functionality is falling into.